cloudmin with CentOS 7 and two network interfaces

I have a system setup with minimal Centos7 install that holds two network cards. one is em1 and the other is em2

Alone the script seems have a hard time with em1 and em2. I had to trick the script by changing the eth0 to em1 in the script so that it could continue and install cloudmin.
regardless of this I got a couple of problems that came up

one was something regarding the digest MD5 when cloudmin booted up, which I believe I fixed by doing ‘yum install perl-Digest-MD5’ following this fix

Then after doing a refresh status fully. I got another error about fuser which I do not recall the full error. either way after doing refresh status fully I finally got into the following error

“This system cannot be a KVM host : No bridge interfaces like br0 were found
Virtual systems cannot be created or added until this is fixed.”

It has been a nightmare trying to get two cards to work. I tried bonding them together, hoping I could simple bridge the bond and away I go. It does not seem that simple. I have tried just using one NIC and add it to the bridge from webmin->networking->network configuration->network interfaces but this seemed impossible as well, mostly because I’m doing it remotely since my server has no gui of course.

I had to manually go to the box, configure /etc/sysconfig/network-scripts/ifcfg-em1 NIC with:

Then create /etc/sysconfig/network-scripts/br0:

I thought I had done this before on a centos7 so I did not understand why I’ve such a hard time. When I checked my old box it was centos6.9 and not 7. And furthermore this box actually had eth* cards so cloudmind script took care of it all.

A couple of questions:
Does cloudmin still have issues with centos7, or is this a script problem not picking up the em1 and em2 cards?

Not being all that familiar with bridging yet, can I make both em1 and em2 go on the bridge or is this just a one nic per bridge thing?

Wouldn’t bonding both my NIC’s then creating a bridge with that bond be a good idea? I fiddle with this enough to drive myself mad…