Cloudmin bug

  • I installed Centos on a bare metal server (with two ip adresses). Created a bridge br1 and installed Cloudmin GPL.

  • Then I created a KVM vps1 from a Centos 5.4 KVM template (downloaded with Cloudmin). So far so good.

  • Status is SSH. And I can also ssh into server from the internet using the automatically assigned IP address.

  • When I run “install virtualmin” but the install hangs in a loop and doesn’t end.

  • Install log and shows (many) messages Hostname vps1 is not fully qualified.

It is probably a bug that the install doesn’t return any error message earlier, right?

And does cloudmin expect me to do anything manually during the installation (for vps1)

Is there a ticket for this? If not, you should probably open one with the same details, and maybe reference this forum post. (Forums don’t provide the tools needed to triage, track and fix bugs.)

The problem is that runs noninteractively in the Cloudmin “Install Virtualmin” case…but it cannot successfully install without a fully qualified domain name (it could install if we ignored that error when run non-interactively, but a number of services will simply be broken at the end of it; a FQDN is not optional for Virtualmin).

I created a ticket for this and Jamie fixed it