Cloned virtualmin server


Simply, i have Amazon host (AWS) i created linux server ubuntu, then i followed the instructions to install Virtualmin then i moved my website (Joomla!) to it and everything going fine without any error.

Then, from AWS i cloned that server completely with new IP address then login to Virtualmin and changed the machine IP to the new one given by AWS.
I opened Virtual servers list and deleted the server which contains the (Joomla!) website and created a new virtual server, to be sure it is working well, i upload a php file to list php info and also uploaded php file contains some php functions, so all working fine.

My problem, when i am trying to install (Joomla! or WordPress) or copy pre-installed (Joomla! or WordPress) on that new server it give me error :
(500 internal server error)

I checked Apache error log then i found:

[Wed Oct 30 15:17:19.306580 2019] [fcgid:warn] [pid 12298] (104)Connection reset by peer: [client] mod_fcgid: error reading data from FastCGI server
[Wed Oct 30 15:17:19.306598 2019] [core:error] [pid 12298] [client] End of script output before headers: index.php
[Wed Oct 30 15:19:09.599163 2019] [fcgid:warn] [pid 21370] [client] mod_fcgid: read data timeout in 40 seconds, referer:
[Wed Oct 30 15:19:09.599215 2019] [core:error] [pid 21370] [client] End of script output before headers: setup-config.php, referer:

I tried all the ways to fix it (based on Google search), most of it talking about permission and file’s ownership, but didn’t success.

any help please !!??

More information about my server configuration:

Operating system Ubuntu Linux 18.04.3
Webmin version 1.932
Usermin version 1.780
Virtualmin version 6.08
Kernel and CPU Linux 4.15.0-1052-aws on x86_64
Processor information Intel® Xeon® Platinum 8124M CPU @ 3.00GHz, 8 cores
Real memory 546.5 MiB used / 980.17 MiB cached / 15.1 GiB total
Local disk space 4.27 GiB used / 480.36 GiB free / 484.64 GiB total

three days and no reply at all

I don’t know if this helps or not, but I tried connecting to " " and was greeted with the Wordpress setup menu. When I look at the url it’s the same as the one reported in the first “code block”.

I know this doesn’t help too much, but accessing the site from the outside seems to work OK. Why you should be seeing this message makes no sense to me.

I did find this article " " … might worth trying to increase the time for php execution to see if that helps. (The default is 30 seconds in my configuration.)