CLI-API - create alias Domain

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.5
Webmin version 2.012
Usermin version 1.861
Virtualmin version 7.5
Theme version 20.12

Related to: Create alias domain via remote api - #2 by Joe

I try to figure out, how to create an alias-domain (via cli-api-cal[) and found the above thread.
But even with the information in that thread, it doesn’t work for me.

Here is what I’d tried:

Virtual-Server:: niceServer.de (existing)
Alias-Of-"niceServer.de: testServer.de (should be created)

I’ve tried:

virtualmin create-domain --domain niceServer.de --alias testServer.de --dns

Return: You still host this domain

If I do remove --domain, I got:

Missing domain name

Is that caused of the bug @Joe noticed in his answer? Or is it already solved?

And, it shouldn’t work via CLI! That’s a bug.

I’ve tested it now on “remote-api” same behavior.
Anybody have a hint, what I did wrong?

the Help command shows a --parent in the command line, may thats needed.
virtualmin create-domain --help
See virtualmin help create-domain for more details and examples

Adds a new Virtualmin virtual server, with the settings and features
specified on the command line.

virtualmin create-domain --domain domain.name
–pass “password-for-new-domain” |
–passfile password-file
[–hashpass]
[–parent domain.name | --alias domain.name |

Thanks for your suggestion @stefan1959,
but unfortunately it even doesn’t work with or without --parent <domain.name>.

I didn’t yet tried to create a new server, as I currently only need to add an alias to an existing one.