ClamAV installation is OUTDATED again (sorry guys, [ runs and hides] )

Sorry to say it, but I’m having trouble with ClamAV again and the error suggests that I’m not the only one but nobody else seems to have raised the point.

For about a week I have been getting an error updating.

Logwatch shows this :-

WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.97.3 Recommended version: 0.97.6
main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
WARNING: getpatch: Can’t download daily-16682.cdiff from
WARNING: getpatch: Can’t download daily-16682.cdiff from
ERROR: getpatch: Can’t download daily-16682.cdiff from
WARNING: Incremental update failed, trying to download daily.cvd
ERROR: Can’t download daily.cvd from database.clamav.

When I run freshclam -v I get the following

“has connected too many times with an outdated version”

This page says :-

Starting from ClamAV 0.9x, whenever your ClamAV engine becomes outdated and the difference between the functionality level required by the CVD and the functionality level supported by your ClamAV engine is more than 3, freshclam refuses to check for updates more often than 6 times per day.

Happy for someone to tell me that I’ve missed something.

Thanks for reading people,


Operating system CentOS Linux 5.9
Webmin version 1.610
Virtualmin version 3.98 Pro


That message is normal, and is safe to ignore.

ClamAV likes to be really loud about things :slight_smile:

A new version will be put into the Virtualmin repo, and that’ll quiet down that message for awhile.


Hi Eric,

Thanks for coming back to me on that.

Apologies, my message wasn’t clear and I guess it is easy to miss my main point of concern which is that both the incremental update is failing as is the fallback download of daily.cvd so there has been no updates at all to the Clam database for a week or so.

Is that still just a case of waiting for the new version ?

Sorry to be a pain.



Try logging into your server over SSH as root, and type these commands:

cd /var/lib/clamav mkdir old mv *.cvd old freshclam

That should resolve the issue you’re seeing.


Hi Eric,

Unsurprisingly, that worked like a charm.

Tanks for getting back.


Hi guys, recently I got CryptPHP, on one domain, so i decided to make all updates on clamav with that occasion.
So can you help with version update instructions? The above solution not working now.


WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.98.1 Recommended version: 0.98.5
main.cld is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo)
daily.cld is up to date (version: 19683, sigs: 1275143, f-level: 63, builder: neo)
bytecode.cld is up to date (version: 242, sigs: 46, f-level: 63, builder: dgoddard)

The above solution was not for that error message (that error message is unrelated to the problem Eric provided a solution for).

The EPEL and Fedora repos take a while to roll out new packages. I’ve got a new package building for CentOS 7, and will tackle earlier CentOS versions once that’s done. It takes a little while to get new versions out.

Also, the ClamAV folks are pretty annoying with that whole “WARNING!” thing being so loud and chattery. I understand they want people to run the latest release, but it’s usually not dangerous to run an older version for a few days while packagers catch up to the latest version, and yet it makes people nervous to see this message.