Clam AV starting hangs the server

Hi - poked around on this a bit but didn’t turn too much up. When rebooting the Virtualmin server the server seems to “hang” on the console and never fully starts. It seems to be a problem with ClamAV startup. Anyone else encounter this issue?

Starting clamd.virtualmin: Limits: Global size limit set to 157286400 bytes.
Limits: File size limit set to 31457280 bytes.
Limits: Recursion level limit set to 20.
Limits: Files limit set to 15000.
Archive support enabled.
Algorithmic detection enabled.
Portable Executable support enabled.
ELF support enabled.
Mail files support enabled.
OLE2 support enabled.
PDF support enabled.
HTML support disabled.
Self checking every 1800 seconds.
Pid file removed.

I do a: /etc/init.d/clamd-virtualmin stop

…and it moves along and the server finally fully boots up, you can log on. If I go run this command to start it again:

/etc/init.d/clamd-virtualmin start

Same things, it sits at “Self checking every 1800 seconds” and just sits there in the command window. It’s quite an irritating thing. I saw that in /etc/init.d there are two clamav startup scripts:

clamd-virtualmin
clamd-wrapper

In the web GUI I also saw them there under startup. I disabled the wrapper, both seem to basically be the same script although I didn’t look at them too carefully.

Any thoughts as to why this startup script is hanging the server and how I can get it to stop :slight_smile:

Thanks!

Howdy,

Hmm, I haven’t run into an issue like that before.

According to your screenshot, it looks like you’re running CentOS 5… is that correct?

If so, what does this command output:

rpm -qa | grep clamav