Checking Configuration...

I performed an update through Virtualmin. Now i am getting this message when i click the check configuration.

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …
Your system has 7.69 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB.
Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add 127.0.0.1 to the list of DNS servers, or turn off the BIND feature on the module config page.

… your system is not ready for use by Virtualmin.

Try following this set-up guide:

http://www.virtualmin.com/node/21899

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add 127.0.0.1 to the list of DNS servers, or turn off the BIND feature on the module config page.

As that error mentions, it sounds like 127.0.0.1 was removed from your /etc/resolv.conf file. That would prevent DNS lookups from working properly if your server is acting as a nameserver for your domains.

You can get that error to go away by adding that back in.

Now, why it’s not in there is another question – there’s two common causes for that, both of which are described in the section “Received Virtualmin error that 127.0.0.1 isn’t listed in /etc/resolv.conf” of this document:

http://www.virtualmin.com/documentation/dns/faq

I looked up the info suggested by andrey and found that the second part of the solution worked.

“If you’re certain – absolutely certain – that your server isn’t obtaining it’s IP address via DHCP – the issue you’re seeing can occur when using a VPS, where your VPS provider automatically overwrites your /etc/resolv.conf file each reboot.”

"If that’s the case, you can get around this error by going into ‘System Settings’ -> ‘Virtualmin Configuration’ -> ‘Advanced Settings’, and set ‘Check resolv.conf for this system’ to ‘No’. "

I have a static IP from my ISP and my web server has a LAN static IP. So not sure why DHCP is involved. Interesting…

Thank you again as always!

Gary