Checking Configuration - Error Message - your system is not ready for use by Virtualmin

Hello, if i check the cofiguration i see this error:

The feature Administration user cannot be disabled, as it is used by the following virtual servers : host.xxx.com xxxx.it xxxx.it xxxxx.com

… your system is not ready for use by Virtualmin

Here are some info and the entire log if I check the configuration.

SYSTEM INFORMATION
os: AlmaLinux 8.8
theme version: 20.21
virtualmin version: 7.7.gpl
webmin version: 2.021

The status of your system is being checked to ensure that all enabled features are available and properly configured …

Your system has 3.82 GiB of memory, which is at or above the Virtualmin recommended minimum of 1 GiB

Using network interface ens3 for virtual IPs

Default IPv4 address for virtual servers is xxx

Default IP address is set to xxx, which matches the detected external address

Disk quotas have been disabled in the module configuration

Shell for FTP users is not included in /etc/shells, which may prevent FTP access

All commands needed to create and restore backups are installed

The selected package management and update systems are installed

Chroot jails are available

The feature Administration user cannot be disabled, as it is used by the following virtual servers : host.xxxx.com xxxxx.it xxxxxx.it xxxxxxx.com

… your system is not ready for use by Virtualmin

The last time I looked, yesterday, the error message was not present.
Can you please help?

Can you at least tell me whether the message should worry me? Should I format and reinstall? The strange thing is that until recently the message was not there. The only thing I did was to upgrade MariaDB to a newer version. But I don’t think it depends on that.

If you search the forums “The feature Administration user cannot be disabled” you will find some other people had the same issue, i think it has to do with the upgrade.

1 Like

Hello Stefan, thank for your reply.
I have already done a search both on the forum and on the internet in general, but nothing useful comes up.

I was hoping for some guidance because I can’t figure out what it means, nor how to fix the error

The feature Administration user cannot be disabled, as it is used by the following virtual servers :

No. You don’t need to reinstall (you almost never need to reinstall, that’s almost always a huge overreaction).

I don’t remember the details, but I believe this is a minor cosmetic bug. I’ll try to find discussion about it in the morning.

1 Like

Thank you Joe

However the recent operations I have done on the VPS are to upgrade mariadb 10.3 to version to version 10.5

sudo dnf module list mariadb
sudo dnf module disable mariadb:10.3
sudo dnf module enable mariadb:10.5

yum update -y
systemctl restart mariadb
mysql_upgrade -u root -p –verbose

I don’t know if the problem is related, but since about 7 days the backup has also stopped working, in the log there are no errors, but the backup files that used to occupy several GB now occupy only a few KB, they are unusable.

Basically the backup problem started since I started seeing the error message mentioned in the title

hi is there any update on this? i logged in today and the system walked me through the setup again. this is my test server and now it will not get past the recheck with this same error.

i checked against the production server and there are two new core items in the test server Features and Plugins

Administration User
Home Directory

both version 7.7

i havent been in the test server in a while so i had not even requested an update.
The website application still appears operational on test, but i would like to know how to resolve this before i update/upgrade production again.

both servers are on 7.7 but the production server Enabled Features does not show Administration User or Home Directory as options but they do show on the test server.
production server Enabled Features


Test Server Enabled Features

The only solution I found was to make a new VPS and redo everything from scratch and then manually transfer everything, as almost nothing worked on the old VPS… a lot of work.

By the way it was very risky, in fact among the various services that no longer worked there was the backup: it didn’t give error messages, but basically the backup files were empty, I noticed this because I did some testing, otherwise I wouldn’t have noticed for quite a while.

Thanks for the reply. It seems your issues were more serious then mine. Everything appears operational including backups. It will not pass the recheck which means I cannot see the dashboard, but so far that seems to be the extent of things.

It’s just odd that my test server (cloned from production for exactly this reason, to test updates!) has what appears to be the same virtualmin version but displays different options on the virtual server.

I need to find the root cause otherwise this may ultimately appear on my production server which is more alarming, so I’ll see what I can find and post an update. If anyone else has any insight it would be appreciated!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.