Changing the php.ini


I am writing a script and when running it(after uploading it to the server) I end up with a blank screen but no errors show up.

After running phpinfo(); I see that error display is turned off.

How do I edit the php.ini file to turn the error display on ?



I actually recommend not enabling those – the errors you’re interested in are in the Apache error_log. You can find those in $HOME/logs/error_log.

Enabling those becomes a security issue, as anyone visiting the site could end up getting a lot more info than they should be able to see should an error occur.

That said, if you really wish to enable them, log into Virtualmin, choose the domain in question, then click Services -> Configure PHP5 -> Error Logging.

In there, you can set "Display error messages" to "Yes".

I’l check out the logs first.

BTW does each virtual server have its own php.ini file ?


If you’re using Virtualmin Pro, then yes, each Virtual Server has it’s own php.ini file.

If you have the GPL version, it uses the system php.ini file in /etc.

Of course I’m a pro :wink:

that is if you choose to run mod_fcgid
in VM Pro you can also choose to run under mod_php and then you’d still have to go to /etc/php.ini

I also strongly recommend to read the virtualmin documentation at least once to learn a bit more about webhosting in general and the software you are using specifically