changes dns records


I installed virtualmin Pro onto a minimal installation of centos OS. I did give into the CentOS installation an hostname (vm10) and a domainname (

When I created my first domain ( the creation went nice within Virtualmin Pro, but the website isn’t reachable. it must be reachable because I use external dns-servers for this domain so I don’t have to wait for the dns-server of virtualmin.

I tried to "ping" them ( also, and that command gives the right reply

I get this error from the webminview:

"Failed to connect to : Connection refused"

So I looked to the DNS records of the virtualmin dns-settings (doesn’t matter because of the external use, but I looked for an explanation of the problem) and I saw som strange paramaters:


This form allows you to manually edit the DNS records file /var/named/

$ttl 38400
@ IN SOA (
38400 )
@ IN A
www IN A
ftp IN A
mail IN A
@ IN MX 5 mail

As I see it, there is something fundamentaly wrong with the template settings.

Maybe someone had the same experience and can help me correct them.

Well, I found the "solution".

When I create a new server with the tools on the left of the screen I got the same error. But when I create a new virtual server with the tools into the main screen everything is going fine.

I tested this (I work with VMWare so it’s a piece of cake to restore the original image) and came to this solution.

Does anybody experienced the same problem?