Changed Port Now "webmail.domain.com" Goes Nowhere

I changed the port from 20000 to 12345(not really) in the Usermin configuration screen.

Am I supposed to go ahead and manually edit httpd.conf thusly:
RewriteCond %{HTTP_HOST} =webmail.domain.com
RewriteRule ^(.*) https://domain.com:12345/ [R]

or is there a handy button somewhere in the interface?

Thanks,
Tony

It’s very easy to update them, all those methods work fine… just thought there might be a button hidden somewhere.

It’s all good now. Thanks!

There’s no way in the UI to update all of those.

Your options are:

  1. Manually update them

  2. Use the modify-web.pl command line script, and disable webmail forwarding, then re-enable it, as documented here:

http://www.virtualmin.com/documentation/id,virtualmin_api_modify_web/

  1. Use a regex, and modify it all at once using a text editor or via the command line. If those are all in one file (as they are on CentOS/RHEL), that’s as easy as running %s/:10000/:12345/g in vim.

There’s no way in the UI to update all of those.

Your options are:

  1. Manually update them

  2. Use the modify-web.pl command line script, and disable webmail forwarding, then re-enable it, as documented here:

http://www.virtualmin.com/documentation/id,virtualmin_api_modify_web/

  1. Use a regex, and modify it all at once using a text editor or via the command line. If those are all in one file (as they are on CentOS/RHEL), that’s as easy as running %s/:10000/:12345/g in vim.