Change webmin url

Hi guys,
I changed the machine hostname since I installed webmin but the url given in the ssl page (This web server is running in SSL mode. Try the URL https://old_hostname:10000/ instead) is still matching old hostname which is not resolved anymore.

How could I change it ?

Many thanks

Hi guys, sorry to bother but no one ever changed a server hostname after virtualmin install ?

Many thanks


It may just be a matter of restarting Virtualmin, if you haven’t already.

But another thing you could try is to go into System Settings -> Virtualmin Config, and set “Virtualmin URL for use in email messages” to your preferred URL. I believe that parameter is also what Virtualmin will use for redirects.


thanks for your answer.
I already tried webmin restart (even machine restart) and did not work. Virtualmin Url neither.

It’s only used when I put url address without https so I guess it has to do with ssl redirect option but can’t find it anywhere.
Already tried to disable and enable ssl forcing too, but no luck with it neither … :frowning: