Change 'sent via' for emails sent from server

Hi,

Apologies in advance about the bad title - I didn’t know how to better explain this!

When emails are sent from our server (e.g. PHP Mail) to certain email clients (such as Gmail), the ‘sent from’ on the email always says:

‘[email address] via [server FQDN]’

For completely unrelated domains, this looks quite strange.

Having read this: http://support.google.com/mail/bin/answer.py?hl=en&ctx=mail&answer=1311182&authuser=1

I’m guessing this may be resolved via a DKIM signature? Can this be achieved via Virtualmin?

Thanks

Hi,

From Google’s own article, it appears that by setting up an SPF record in your DNS settings indicating that the sending server is authorized to send mail on your domain’s behalf, this will correct the matter. This along with signing your messages with DKIM signature.

Both of these can be setup inside Virtualmin.

If you require a step-by-step, or further assistance feel free to ask.

Alternatively, for a small fee I can through a screen sharing session get this setup for you :slight_smile:

-Peter

Hi Peter,

Thank you for your advice.

I’ve ended up getting my head around SPF/DKIM, as I would have felt bad asking you to explain in more detail, and even worse for paying for something I can learn about!

It seems I cannot setup DKIM on Virtualmin, as I haven’t got Mail enabled for the domains in question as the emails are being sent by PHP mail, but just adding an SPF record for the domain with the server’s IP/FQDN has resolved the ‘sent via’ problem.

Thanks for your help!

Adam