Change home directory for Lucee

I have set up virtualmin and have installed Lucee on the same server which is used for coldfusion . now I need the home directory for virtualmin to point to Lucee webapps folder


because Lucee runs all it’s backend through that folder . my question is how do I change the home folder (including file manager) to see that folder.

I have changed document root to this address in httpd.conf but that did nothing. any help would be appreciated.


Ok I went to: Virtualmin > Server Configuration > Change Domain Name and adjusted “Change home directory” which worked great but the top folder ( is where files need to be. Virtualmin has put public_hmtl into that folder so to browse you have a url that looks like this.

Any suggestions?


If this is the only virtual server that will need an odd path, just change it in the Apache configuration. Where that is depends on your OS/version, either /etc/httpd/conf/httpd.conf or /etc/apache2/sites-available. Find the DocumentRoot and Directory directives and remove the public_html bit from them. (There may be multiple instances you need to change, if you have SSL enabled.)

If you want new domains to use a different docroot, use Server Templates to change it, under the Apache website section.

Hi Joe . actually I got it all to work perfectly just leaving everything standard on virtualmin and updating the httpd.conf file with the normal Lucee structure .

I don’t know if you are able to but I would like a way to open one folder to lower accounts which is in opt/path… Is this possible. I am a programmer so I can change the code if you could show me how. I run lucee (coldfusion) so their html folder is not in public_html. I need to allow them access to the webapps folder in the opt/path… folder