Change global ip, problem validating virtual server

So I was moving my server the other day, it acts as a master-dns and sends records to a slave at my registrar. When moving the server I edited each record by hand to make it reflect the new ip, using dig everything looks alright. And the glue record was changed at my registrar. However some site’s are still flaky, sometimes they resolve to the old IP, but the move was 5 days ago, it should have been propagated by now, right?

So naturally I started investigating what could be wrong.

Some site’s show all OK, but others gives me this:
BIND DNS domain : The DNS record resolves to the IP address XXX.XXX.XXX.XXX instead of the virtual server’s IP XXX.XXX.XXX.XXX <- this is the old IP.

I guess my settings are set up around the local IP, and I have Default IP address for DNS records set to Automatically detect external address

And Default virtual server IP address is set to From network interface

Any ideas what might be going on here?

I had this too after replacing my server which was set up first at home.
What I did was in virtualmin - system settings - module config - networking settings:
Network interface for virtual addresses; set it manually to eth0 if you use that
Default virtual server IP address; set it manually to the external IP

I noticed that somehow from somewhere deep in the system apparently old settings could submerge under unindentified circumstances and ruin the party. I haven’t found from where and I stopped looking for it though.

Haha, funny thing, I actually tried this right after posting, I still get the validation error:/

Also if you are authorative for those domains then switching IP means that the IP needs to propagate as well.
You may want to try this again in a few hours. Also check the zone files for those domains just in case…

Tried again today and the same error occurs:/ I also have people around the world reporting that they get a 504 gateway timeout sometimes.

I just found out that
Edit Virtual Server > IP address and interfaces had external IP adress set to the old global ip.

I went through all sites and changed this, but in the dns i see that there are two ip: on mx, like this: IN TXT “v=spf1 a mx ip4:XX.XX.XX.XX ip4:XX.XX.XX.XX ?all”
Both are identical, i recon i should remove one of them? in some of sites one of them are set to the local ip…

Appears that the slave-DNS is still using the old IP aswell, hopefully this will change after the changes i did above…

you should remove the slave and re-enable it. I had the same issue actually, but on my master it was set to allow transfers from the slave (dumb yes)
when re-enabling it choose the options to create the zones on the slave obviously…

Ok, thanks. DNS is very new to me, how would I do this exactly? I followed this guide to set it all up to begin with:

Noticed that “Notify slaves of changes?” is set to yes, shouldn’t this setting really take care of things?
I also have allow transfer from slave, did you remove this aswell?

EDIT: I think I found it now, so I removed slave and re-added it.

In my logs I keep seeing: “the working directory is not writable” And I’ve search a little on this error, my /var/named/ is root.named and /var/named/chroot/var/named is named.named , does this have anything to do with my problem? I’ve never touched those permissions before I encountered that error.