CentOS6 Dovecot 2.0 Email issues

Hello All,

I am somewhere between a beginner to moderate on experience scale. I installed a basic CentOS 6 on a VPS and then installed Virtualmin via install.sh. Got all my backups restored from my old Virtualmin host. Everything works great but mail. It is getting to the server, but I can not get a mail client or Gmail to connect to any of the domains on the server, also can’t send mail. It always errors out (times out or connection refused. I have tried SSL no SSL. doesn’t seem to matter.

I updated some of the settings via Virtualmin however it I had to modify the config through the editor because some of the settings where formatted incorrectly (I am guessing because Dovecot 2.0 is new.)

Anyway some pointers would be great to get everything going. I do not care if SSL is on, my only concern is it working.

Howdy,

Well, let’s start here… can you send/receive email using a webmail app such as Usermin? Usermin is available on port 20000 of your server.

The next step is to look at your mail logs, in /var/log/maillog, to see if any errors are occurring when you try to send/receive messages.

-Eric

When using Usermin: “An error occurred listing mail in this folder : Failed to connect to localhost:143 : Connection refused”

I was able to send mail from Usermin.

The log has “warning: do not list domain myxaraya.com in BOTH mydestination and virtual_alias_domains” lots of times

Howdy,

You may want to try restarting Dovecot, and then look at the mail logs immediately after. If something is going wrong with it’s ability to listen on port 143, that should show up when restarting Dovecot.

-Eric

Below is what I got after restarting Dovecot.

Oct 22 05:02:28 myxaraya dovecot: master: Warning: Killed with signal 15 (by pid=28664 uid=0 code=kill)
Oct 22 05:02:28 myxaraya dovecot: master: Dovecot v2.0.beta6 (3156315704ef) starting up (core dumps disabled)
Oct 22 05:02:43 myxaraya postfix/anvil[28461]: statistics: max connection rate 1/60s for (smtp:116.44.172.41) at Oct 22 04:59:23
Oct 22 05:02:43 myxaraya postfix/anvil[28461]: statistics: max connection count 1 for (smtp:116.44.172.41) at Oct 22 04:59:23
Oct 22 05:02:43 myxaraya postfix/anvil[28461]: statistics: max cache size 1 at Oct 22 04:59:23

Restart dovecot with

/sbin/service dovecot restart

and post what you get

I got:

Stopping Dovecot Imap: [ OK ]
Starting Dovecot Imap: doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:80: ssl_key_file has been replaced by ssl_key = <file
[ OK ]
After fixing that I got:

Stopping Dovecot Imap: [ OK ]
Starting Dovecot Imap: [ OK ]

Still can’t get mail