CentOS v5.2 - Updating PHP from v5.1.6 to v5.2.6

this worked perfect for me tabletguy.

after you do this however, is it advisable to disable the bleeding edge repo?

i notice when i try to install something new for zip, because i’ve been trying to do “pecl install zip” without success, that it does this:

yum install libpcre3 libpcre3-dev
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • addons: centos.mirror.netriplex.com
  • base: mirror.batblue.com
  • extras: mirror.ash.fastserv.com
  • updates: ftp.usf.edu
    virtualmin-bleed | 951 B 00:00
    Reducing Red Hat Enterprise 5 - x86_64 - Virtualmin Bleeding Edge to included packages only
    Setting up Install Process
    No package libpcre3 available.
    No package libpcre3-dev available.
    Nothing to do

also i agree, that the wiki page should include an example. it would be great. i know that you do a lot in supporting this repo however and we all appreciate your generosity.

I’m not sure if there is a newer thread, but I was wondering if there have been any known issues with updating to php 5.2.x with these bleeding edge repos… If so any idea for what? I basically have a few scripts I want to run that require it.

worked fine for me. You could also try to upgrade to 5.3 (centos 5.7), but 5.2 worked better for me.

Thanks. Ummm I am running Centos 5.7 and I only have the PHP that comes with Virtualmin. I did a base install of Centos to make sure Virtualmin installed and worked as best possibly. Recommendations? Use the bleeding edge or go a different route to get to 5.3?

php 5.3 is included from Centos 5.6. Try yum search php

Ok well this is what happens if I do

yum install php

Package php-5.1.6-27.el5_7.5.x86_64 already installed and latest version
Nothing to do

Sure, I can manually install it but my Centos 5.7 does not have a php > 5.1.6

I found best article describing in details, It is worked me fine


here’s what I did to get this updated on my server, seems to have gone well apart from ‘mcrypt’ extension is missing. not a major issue at the moment, but unsure how to install mcrypt

rpm -ivh http://software.virtualmin.com/bleed/centos/5/i386/virtualmin-bleed-release-1.0-1.rhel.noarch.rpm

yum update php

edit: did a “yum install php-mcrypt” and it seems to have worked by taking mcrypt from the bleeding edge repository

just a big thanks to you guys,
once I got my head around how you have things set up (wasn’t too difficult :o) ) its been really easy

I wasn’t sure about your bleeding edge repo (I mean how to use it), but its great.

best web admin I’ve ever used.

cheers Brian