Centos 7 x86_64 - not functioning properly "Out of the Box"

I’ve had Centos 6 x86_64 and now decided to move to Centos 7 x86_64 due to newer PHP version but it is not functioning properly “Out of the Box” as expected
Server is on VDS. Let me explain problems so far:

  1. After installation I’ve run Post-Installation Wizard and choice of Run ClamAV Server Scanner (Yes/No)
    When I’ve selected Yes got this:
    A problem occured testing the Clamav server scanner:
    ERROR: Could not lookup: Servname not supported for ai_socktype
    Don’t know workaround still

  2. In MySQL says that we have to set root password for MySQL, when I do that, I get error:
    DBI connect failed : Access denied for user ‘root’@‘localhost’ (using password: NO)
    fixed by simply going to Webmin>Servers>MySQL

  3. Tried to move all my iptables rules - iptables in this Webmin does not exist (however package seem installed).
    There was a mention somewhere on forums that firewall been changed to firewalld (i didnt see that package installed)
    Anyway I prefer iptables, so fixed by doing this:
    yum install iptables iptables-services
    and copied my old backed up rules from /etc/sysconfig/iptables

  4. When I was doing restore from backup
    virtualmin restore-domain --source /root/backups/virtualmin.tar.gz --all-virtualmin
    I saw loads of strange markup symbols (like "=== "
    or “Installed:

    … install complete.

    … not installed”


"Restoring greylisting settings …
Installing package(s) with command /bin/yum -y install postgrey …

Loaded plugins: fastestmirror"

and then during restore gone in to major issue, which is ProFTPd
"Applying FTP server configuration ..
.. failed : Job for proftpd.service failed because the control process exited with error code. See "systemctl s      tatus proftpd.service" and "journalctl -xe" for details.

4) See above ProFTPd does not work out of the box:
When trying to start I get this:
"Failed to start service : Job for proftpd.service failed because the control process exited with error code. See "systemctl status proftpd.service" and "journalctl -xe" for details.

Any advice on how to fix all these? Many thanks!

I notice that with Centos 7 minimal there are some problems, missing dependencies and some other stuff but this is not the case with Centos 7 full what actually work out of the box. You should try to reinstall Centos 7 (full not minimal), make full update and then proceed with Vmin installation. See what problems pop out after that and dont forget to finish Install wizard and (re)check configuration before you continue with adding domains/virtual servers.

Few more “it could happen” problems:

  • clamav dont want to start: Use ssh and “systemctl start clamd@scan”. You just need to do this once.

  • cant connect with FTP: Disable SFTP (https://www.virtualmin.com/node/20661 - last few post) but i would rather stay with SFTP and close port 20/21.

The rest should work.


Yeah we’ve been seeing some issues lately when the MySQL password is set prior to running the Virtualmin installer. The next Virtualmin version is going to handle that case better.

And yeah many people do prefer iptables, what you did there is a good method for switching over to it rather than firewalld.

Regarding FTP – what do you see in the logs when that error occurs, or when running the commands mentioned in that error output?

Lastly, you mentioned some strange symbols during a restore – does the restore actually work, but the display is odd? Or does the restore fail in that case?


unfortunately my VDS provider does not have that option - template for Centos OS 7 comes “as is”. And I guess I have to install some packages by hand to make it full, not minimal
Also this happens https://www.virtualmin.com/node/36165
(sending emails via SMTP does not work by default - service has to be started manually)

regarding FTP, yes if port 2222 and SFTP engine is commented out it does work
restore from backup halts when applying FTP settings due to the same issue (it works after I fixed ftp config)
Also as was suggested FTPS is better than plain FTP - when I was trying to make it work (and it seem to work now) >Webmin>Servers>Proftpd>Edit config files - is this line important in ProFTPD configuration?
“SFTPHostKey /etc/ssh/ssh_host_dsa_key”
(I don’t have that file at all)

Then use “ssh-keygen -t dsa -f /etc/ssh/ssh_host_dsa_key”.

continuing to this topic - email doesn’t seem to work. It has Postfix, it seemt to work but eventually it stops and any email sent to any domain comes back with this:

“Message will be retried for 0 more day(s)
Technical details of temporary failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain domain.com by domain.com. [xx.xx.xx.xx].
The error that the other server returned was:
451 4.3.5 Server configuration problem”

Wierd thing is - I don’t see any log files for Postfix in /var/log - there is no maillog or mail.log at all! So not possibly to check if it works properly and what the cause of the problem is.
A bit annoying as Centos 6.7 worked without a glitch =( Centos 7 seem to need a lot of work (or maybe it’s just my VDS provider that has a bad template for the system - I guess it is very minimal installation, then why install.sh script doesn’t pull all the dependencies from start?). Thinking of moving back to 6.7
Any way to fix this Postfix problem? Thank you!

Try to use telnet and connect to your server on port 25 and see if it works.

telnet in 2016 = bad idea