CentOS 7: Webmin BIND service not starting, backups failing as a result and more

Centos 7.9.2009 REQUIRED
Virtualmin version 7.1 REQUIRED

Been noticing my Virtualmin backups are failing. The first virtual server fails at " Copying records in DNS domain … domain not found!"

Dug around and noticed BIND DNS server is not started and it won’t start, at least not in the dashboard. When opening BIND in Webmin it presents a setup screen for BIND with three choices - this is new as it was previously set up. I ended up re-setting it up anyway but then I got a chroot error message and giving me an option to go into module configuration.

I ended up with none of my domains having any DNS Zones showing up. I’d go on but it seems to have fixed itself after made a change and then changed back, and I can’t tell you exactly what I did, but I think it had something to do with chroot. There’s a bug causing the above, but I am not sure where/what. Eeek.

Stop doing things. Webmin is somehow confused about how BIND is configured.

It either thinks BIND is configured to use a chroot, and it isn’t, or vice versa. You need to switch the config in Webmin to match how your BIND is actually operating (either in a chroot or not). You don’t want to start over from scratch. You want Webmin to know where you actual configuration is.

I’m not sure how this would happen, as the config files don’t change unless Webmin is reinstalled (you should not do that), or it gets changed by something else (did you run virtualmin config-system? you should not do that for services that are already in production). I’m not sure what else could cause Webmin to change config like this once things were already running, but, I’m sure there are other possibilities.

Thanks for the quick reply. Other than doing a yum update I haven’t done anything to the server or made changes in months. This issue started two days ago and I only noticed because my backup email showed errors.

Everything appears to be working just fine now. FYI I don’t use the server for DNS and it’s all done externally. Still, the config getting messed is a complete mystery.

Curious, how do I determine if my system is setup to have BIND use chroot?

Thanks again

Then why the heck is BIND even running or enabled in Virtualmin?

Disable that feature in Features and Plugins and disable the service and stop it.

1 Like

Well, I am in the newbie zone. Seriously though, I don’t think I ever meant to enable BIND but something was off on my server and I got confused. Everything appears to be working now but I really don’t know why. Thanks for the help.

Oh, I am getting this error when trying to remove BIND from features and plugins:

Failed to save enabled features : The feature BIND DNS domain cannot be disabled, as it is used by the following virtual servers :

I think if I go to Edit Virtual Server for each virtual server and uncheck “DNS domain enabled” that will solve the problem. Is there a better/proper solution? Does it matter if BIND is setup and running if I am not actually using it?

Virtualmin Pro allows you to perform mass update for all virtual servers using UI. Using Virtualmin GPL you can disable DNS feature one by one by editing each virtual server individually.

Also, I do not see how your Webmin BIND config happened to be messed up after Webmin upgrade. This is not something should happen nor something I could reproduce.

If your DNS is hosted elsewhere you generally don’t need BIND running locally.

we discovered more or less the same situation in Webmin yesterday. We have 2 CentOS7 servers for private DNSs and use Webmin for managing the registers. As one of our users suspected a DNS problem, we have done a check and Webmin reply is that BIND is not running (by the way it is false: BIND services run flawlessly). Then it appears that Webmin is now unable to give the right answer about the service. As for jmunjr we have automatic yum updates running. We probably encountered the problem with the same update load.

Yes, this issue doesn’t break BIND service itself. It breaks Webmin BIND module config, which stops seeing system BIND service at the right place.

The fix for this issue is as simple as that –

Sorry about that.

Thank you so much for the info! I will jump on it :slight_smile:

And I confirm it works :grin: :ok_hand: :pray:

I am having the same issue, but it seems I am unable to turn off the “DNS domain enabled” feature. Whenever I do so, I am taken to the confirmation page:

Are you sure you want to save the domain xxx.xxxxxxx.com? The following features have been selected for deletion:

  • DNS domain - All DNS records in the domain and any BIND options will be deleted.

Then it goes on to delete

Removing records from DNS zone xxxx.com
… DNS zone does not exist!

Saving server details …
… done

but when I go back to the Virtual Server Details, DNS is enabled again. This is a subdomain!

When I go to Webmin BIND server, I see this message

The primary configuration file for BIND /var/named/chroot/etc/named.conf does not exist, or is not valid. Create it?

Ok, I managed to solve it. In Virtalmin, under Disable and Delete, there is an option to “Disassociate Features” which did it for DNS. phew :slight_smile:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.