CentOS 5.2, VirtualMin 3.62.gpl, Cannot send mail

I just installed VirtualMin 3.62.gpl on a CentOS 5.2 box using the installer script. Everything appears to be working great except the fact that I cannot send email through my server using a mail client such as Thunderbird or Windows Mail.

When I try to send an email, I get the following error in my maillog.

Oct 21 11:14:47 pdx postfix/smtpd[11266]: warning: SASL authentication failure: Password verification failed

I’ve made sure my email client is setup to use SMTP authentication and I am typing my credentials in correctly. But just keeps coming back with this error.

I’ve verified saslauthd is running

[root@pdx sasl]# ps aux | grep sasl
root 10714 0.0 0.0 5488 472 ? Ss 10:48 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 10715 0.0 0.0 5532 1008 ? S 10:48 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 10716 0.0 0.0 5532 1008 ? S 10:48 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 10717 0.0 0.0 5488 264 ? S 10:48 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
root 10719 0.0 0.0 5488 264 ? S 10:48 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam
postfix 11161 0.0 0.1 8232 2692 ? S 11:08 0:00 smtpd -n smtp -t inet -u -o smtpd_sasl_auth_enable yes
postfix 11165 0.0 0.1 8248 2724 ? S 11:09 0:00 smtpd -n smtp -t inet -u -o smtpd_sasl_auth_enable yes
root 11203 0.0 0.0 3908 672 pts/0 R+ 11:11 0:00 grep sasl
[root@pdx sasl]#

Another forum suggested I try the following commands.

rm -r /var/run/saslauthd/
mkdir -p /var/spool/postfix/var/run/saslauthd
ln -s /var/spool/postfix/var/run/saslauthd /var/run
chgrp sasl /var/spool/postfix/var/run/saslauthd
adduser postfix sasl
/etc/init.d/postfix restart
/etc/init.d/saslauthd start

This did not resolve my issue.

I have my email account setup on my blackberry and I can send/receive just fine. Why is this? Why won’t it work for thunderbird or windows mail? Is this a client or server configuration issue? I am stumped. I would think the virtualmin script installer would have setup everything the way it needed to be to work.

Please help. I need to be able to send mail.



What is the format of your username?

If it’s “user@domain.tld”, you’ll need to make sure that saslauthd is being launched with the -r parameter (how exactly one does that depends on the distro being used).

Barring that, do you see any other errors when attempting to authenticate? Anything unusual show up after restarting Postfix?


I do not notice anything unusual in the logs when I restart postfix or saslauthd. I am also using "user@domain.tld" usernames. How do I set saslauthd to launch with the -r parameter? I am a bit new to this. I am more familiar with sendmail than I am with postfix. :slight_smile:

Thank You,


Ok I figured out how to start saslauthd with the -r parameter. Everything appears to be working great now. I can send and receive. Thanks for all your help. :slight_smile:

At least post your solution so we all can learn. I too want to know how to do smtp authentication.