Can't visit the domain when created a new server under Virtualmin


I’m new here, just recently started to explore Ubuntu and Virtualmin,
I setup a SSD Cloud Hosting a week ago, running Ubuntu 12.04 x64 on the server and then I installed Virtualmin GPL 2days ago.

Everything went well and successfully install Virtualmin with Webmin, until things went wrong after I set-up a domain by created a new-server under Virtualmin page.

The problem occurs when I visit my url/domain, it straightaway prompted me that the page is unavailable :


You don’t have permission to access / on this server.

I take 2 days explore the Virtualmin & Webmin settings and as well as google’ling around the pages for related problem.

Finally I came to realize the problem, under Webmin>Servers>Apache Webserver is due to my domain ‘Address’ is not set to ‘ANY’ instead the address is set as my clouddomain ips
So i Click my domain to hope i can configure it from XXXX.XXXX.XXX to ANY, but show that I can’t edit it when i read this line :

This Apache virtual host belongs to the Virtualmin server, so the address, port, base directory and hostname cannot be changed here.

I go back the Virtualmin page and click one-by-one to see any setting that can be done. I really can’t solve this problem by myself…

Can someone tell me how to deal this problem?

The “You don’t have permission” message is a bit misleading. It just means that there is no web content yet for the newly created domain, thus no index file to serve, so Apache somehow thinks you’re not allowed to view that “page”.

Take a look at /home/DOMAIN/public_html and put your stuff there. :wink:

Hi Locutus,

I did that with a simple test.html and also FTP wordpress into /home/domain/public_html as well but is not working.

Later I found out is due to the domain is restricted to my Cloudserver IPS. is assigned to my CloudServer Ip’s 123.123.1234 That is why no user can visit the page.

I need someone to teach how change the Address. Attached my image to let you understand my problem.

I don’t really understand… It is correct behavior that the domain is “assigned” (in terms of Apache virtual host) to the external IP address of your server. It can, but should not be “ANY”, since this can lead to problems with selecting the correct vhost to serve.

Is the IP incorrect? What are the actual IP addresses involved?

Since you receive “permission denied” errors, that’s not caused by a wrong IP address. You might want to check Apache’s error and access logs for further details about why access was denied.

Thank you. Four years later, but still, much appreciated.