Cant update from PHP 7.0 to 7.2 (FPM). Pretty sure something with virtualmin (possibly php.ini file regeneration?) is broken

Virtualmin 6.02 / Ubuntu 16.04

Hi there,

Installed php7.2, but over the course of a day and a half it seems I’m unable to get php7.2-fpm to be the default.

While only the php7.2-fpm mod is enabled in Apache, Phpinfo still shows etc/php/7.0/fpm

Based on the comments in this post: https://www.virtualmin.com/node/56747 I tried uninstalling all versions of php other than 7.2, however that didn’t help.

It seems I’m unable to get virtualmin to generate a php7.2 folder inside of /home/[domain]/etc/

When running Re-Check Configuration I see:

“PHP versions have changed […] Regenerating any missing php.ini files”

However, no new php7.2 folders (or updated php.ini symbolic links) are created.

All domains are set to use FPM in Server Templates. And Default PHP version is set to latest version.

I also tried to manually change Default PHP version to 7.2 in Server Templates, however this also had no effect.

Note: I don’t need to be able to switch between multiple PHP versions per domain (though that would be a nice feature!). Would be happy just to be able to get 7.2 working for all domains.

hello , have you find a solution , i have the same issue
thanks

no sorry

have your tried to stoped php-fpm old version and started only ph-fpm new version

Then recheck config.

Changing php-fpm is risky and tiring process though.

hello, I have uninstall apache2, and all php -> re-install apache2->re-install php7.2 with dependencies. and re-check conf on virtualmin . now it’s working … thanks

I am having the same problem.
I have php versions 7.0,7.1,7.2,7.3 however FPM is only v 7.0.

What shits me about this, i installed virtualmin only a week ago from the auto installer script on downloaded directly from virtulmin website. I dont understand how i ended up up with an old version of FPM?

I have websites on my server.

How do I get virtualmin to recognise the latest version i have installed in webmin>software packages/package from apt, without stuffing the live websites on it?

Is there an update on this…I am looking at a big vacume of repsonses to a rather annoying problem.

My understanding is that we are supposed to always run the latest version of apps and software…often for security reasons. So with that in mind, and since this is searchable on google and the whole world can therefore read this complaint, is there a solution yet? (in the absence of a solution ill just keep posting this to keep it ranking on google searches.)

OP Update. As of now, 4 months later, I’m still at 7.0.

For those looking for a solution (the following options aren’t really feasible for my case, but may be useful to some) the nuclear option of uninstalling Apache mentioned by bruno.rotrou might work.

Alternatively, Eric suggested in another thread (https://www.virtualmin.com/node/60387) that PHP 7.2 FPM should work out of the box with Ubuntu 18.04.

Interestingly Eric also stated that:

“What you’d need to do though is disable the existing FPM config in Apache, and then install a newer PHP-FPM version from the SCL repo (the same repo where you’re other PHP 7.x versions came from).”

While this was in response to a question about CentOS/RHEL 7, rather than Ubuntu 16.04 with the Ondřej Surý PPA , it mirrors what I believe I tried to do and assumed should work before posting here.

It may be that Virtualmin only creates the necessary config in certain scenarios. One guess is it’s possible Virtualmin only does so when first setting up Apache/PHP, although that wouldn’t explain why upgrading to PHP 7.0 FPM seemed to work previously, whereas moving to 7.2 FPM doesn’t.

Alternatively it may be that there is something slightly different to how Virtualmin works with 18.04 vs 16.04.

While the Virtualmin team would probably have a better idea of why this might be failing than us, it is completely understandable that they just might not had the opportunity to investigate due to their workload.

that may be the case…although i am using debian 9 and still cannot get past this.
I cannot understand why there isnt a simple solution to it. I have a production server with client websites on it, i am not that keen on the idea of uninstall apache and reinstall it.

At present i am seriously working on a plan to move everything to Centos Web Panel. I cannot put up with these kinds of “stuck in the mud due to limited or no response from developers on forums anymore”. That simply is not good enough. If they cant support the forum, they cant support paid users either. In the event of little or no developer input into important forum issues, we rely heavily on documentation to resolve these kinds of issues. Unfortunately, there isnt anything i can find to help in docs either. I am finding myself going to the ISPConfig developers forums for help as they are active on their forums.

The troubling part about this is, in terms of google searches…these forums are going to be quite visible to most people before private support requestst are. So for public face, i would have thought that the emphasis for business success should focus on public image that is visible in google search engine results.

These negative comments complaining about lack of responses and support are starting to build up…which is only harming this brand name enormously!

For things such as this, when this could be not just your average plea for help but could be looked at as an official bug report (this really should have worked), then I encourage you to report them in the place where the devs look at everything,

https://www.virtualmin.com/project/issues

In there, if you need help with something that one might fix himself or herself, you only get support if you’ve got the paid version of virtualmin.
But if it’s to report a bug, then you’ll be read (and not given support, except in the form of having the certitude the devs will have noticed, will officially acknowledge it, and will fix whatever must be fixed with their next virtualmin update.)

@adamjedger I realise it can be frustrating but I believe the Virtualmin team are trying their hardest with limited resources. This is an open source project and the issue tracker is also open, not private. If people are unable to work through the code themselves then paying for a support ticket is a surefire way of relieving that frustration, as well as helping to support the project.

Thanks to @OliverF I had another look at the issue tracker and found a thread I’d somehow missed over multiple previous visits that now addresses this issue.

Thanks in large part to the hard work of @draxius who tracked down some bugs and created fixes, this issue should now hopefully be resolved and can be patched manually, or people can wait for the fix to be rolled out in a future version of Virtualmin.