can't set virtual server quota limits

hello there, i have enabled quotas AFTER i installed virtualmin and created several virtual servers… now i want to set some disc space restrictions but can’t find those options… ive looked in “Edit Virtual Server”, “Edit Mail and FTP Users” and “Edit Owner Limits”… also when i click “Create Virtual Server” it doesn’t give me an input box where i can enter a certain amount of gb anymore which im sure it did on my other mashine…

again… disk quotas (users & groups) is enabled for /home/ and listed in "webmin->system->disc quotas" so im assuming virtualmin should recognize it…

am i missing something? help much appreciated…

You should go to System Settings -> Server Templates -> your template -> Administration user

On it you can change the Default quota for entire server and the Default quota for server administrator user.

but that’s just the template (the default setting when creating a new virtual server)… i dont think it’s going to have any effect on system wide settings or existing virtual mashines… and it’s defaulted to 1GB anyway which makes it even weirder that i can’t see/change that option when creating a new virtual server or editing an existing one…

Existing virtual server quotas can be edited in the "Edit Virtual Server" page in the section labeled "Quotas and limits"

Joe, I only have the following tabs on the edit server details page.

virtual server details
configurable settings
related virtual servers
enabled features

(latest version of virtualmin gpl)

Is there any condition (if statement) wrapped around the quotas tab? I don’t understand why its not showing up.

Does Virtualmin know you have quotas enabled? e.g. when you do a configuration check does it pick up that quotas are available?

ah… perfect… the tab shows up after i rechecked the config… thanks so much!