Can't send email from client: Relay access denied

Hi,

I’ve looked at so many other forum posts regarding this and I have still got nowhere with it. One thing I’ve noticed is that my postfix config seems a lot more empty than most others. I’m able to send/receive mail from roundcube without problem. I’m able to receive mail in my client (thunderbird), so that’s ok. All I’m unable to do is send out emails via my email client. This happens across all the virtual domains hosted on my VPS. I’ll post errors / config first and then what I’ve tried underneath:

maillog error:

Apr 27 04:23:03 dedivps-31106 postfix/smtpd[29068]: connect from cpc30-hudd10-2-0-cust384.4-1.cable.virginm.net[86.3.65.129]
Apr 27 04:23:03 dedivps-31106 postfix/smtpd[29068]: NOQUEUE: reject: RCPT from cpc30-hudd10-2-0-cust384.4-1.cable.virginm.net[86.3.65.129]: 554 5.7.1 dan.nuttall@gmail.com: Relay access denied; from=nutman@badnutbeats.co.uk to=dan.nuttall@gmail.com proto=ESMTP helo=<[192.168.0.6]>
Apr 27 04:23:05 dedivps-31106 postfix/smtpd[29068]: disconnect from cpc30-hudd10-2-0-cust384.4-1.cable.virginm.net[86.3.65.129]

postconf -n:

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
recipient_delimiter = +
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
unknown_local_recipient_reject_code = 550
virtual_alias_domains = badnutbeats.co.uk badnutwebdesign.co.uk paper-caper.co.uk insulation2you.co.uk tomsvoyage.com byronstreetsocial.com soundreviews.co.uk
virtual_alias_maps = hash:/etc/postfix/virtual

Thunderbird setup:

server: mail.domain.co.uk
port: 25
user/pass: same as inbound
auth method: normal password
connection security: If none then thunderbird gives error: The mail server responded: 5.7.1 Relay access denied
If TLS then: The message could not be sent because the connection to SMTP server timed out.

I’ve tried just about every thunderbird configuration you could think of and all I ever get is one of the 2 above errors.

What I’ve tried to do with postfix config:
add: mynetworks = 192.168.1.0/24 127.0.0.0/8
add a whole bunch of smtpd_recipient/relay_restrictions:
permit_mynetworks
permit_sasl_authenticated
reject_unauth_destination
add: relay_domains = $mydestination

Curiously, I haven’t removed the smtp_relay_restrictions as they were in the config since I started editing it so I thought they should be there, but looking at my postconf -n they’re not there. Why is this?

Anyway, I think that’s everything I’ve done so far. Any help would be so much appreciated! I’ve been at this for days now :expressionless:

Thanks in advance,
Dan

Similar problem for me here, luckily, after comparing with a working VM server. The configuration was missing the following information in the Postfix SMTP Mail server Options under “Restrictions on recipient addresses”: permit_sasl_authenticated

old options were : permit_mynetworks reject_unauth_destination
new options are: permit_mynetworks permit_sasl_authenticated reject_unauth_destination

All good after that.