Can't save edit on the home directory of a VPS user once set

SYSTEM INFORMATION
OS type and version Debian Linux 10
Webmin version 1.999
Virtualmin version 7.1-1
Related packages SUGGESTED

I want to create a temporary VPS user to allow him SSH and check something.

I went at the domain, Edit users, created the user, under Quota and home directory settings, set the Home Directory to something and save.

I wanted to modify the value of the field, but it keeps being the same and now I’m stuck. (ok I can delete the user and recreate I guess). But look to me like a bug and should be fixed.

I made a video but it can’t be uploaded.

On very related topic, if I assign to a user an existing directory and then delete the user the directory shouldn’t be deleted (especially if it is public_html). :wink:

Hello Bernard!

It seems you carried out the standard operation to add a user to a virtual server. To enable SSH access for the user, could you go to Webmin → System → Users and select an appropriate shell from the drop down options offered?

Also see:
https://archive.virtualmin.com/node/10642

And
https://archive.virtualmin.com/node/41734

Hello Niel,

Yes and thank you for the suggestions I’ve been there already.

Using Webmin → System → Users, the user is created, but or the connection is refused or the password is incorrect. :man_shrugging:t2:
I guess I’m not giving the right information at the login.

Using the Domains, Add a users worked fine after I understood how the login should be set;

ssh username-domain.com@my.ip.xxx.xxx -p pppp

As I have no time to invest to understand the why, it was good enough.

However, I wanted the extra confort to drive the user directly into the directory I wanted (many Tikis installed :joy:). But I found this bug about updating the value of the Home Directory.

Thanks again and take care

PS: before this discussion goes in every direction, I’m just reporting a bug, I have a workaround.