Can't retrieve file via URL - PHP Configuration

When I was on a VPS using plesk I was using a PHP script to do pseudo streaming with xmoov-php and flowplayer. I can’t get it to work now with the virtualmin install.

for trouble shooting, I am supposed to be able to put the file in the URL and it should prompt to download the flv file.

The instructions are here.

It worked previously just fine before the new server with virtualmin.

But for some reason it won’t recognize the file and firebugs shows 0 for the size. Of course if i go to the file directly it does try to download it. Since it wont work with the streamer.php file in the URL, it won’t work in Flowplayer. Some how the configuration is not right or maybe its the fcgi. Not sure. I’ve never used fcgi before using virtualmin.

What can I check for? Please help.


Well, you do always have the option of switching to mod_php if that’s what you had success with in the past. You can give that a try by going into Server Configuration -> Website Options, and setting the PHP script execution mode to “mod_php”.


Thanks. I just give that a shot and that didn’t help.
I even compared my previous php.ini on the old server. Really isnt different except for the values of max execution and stuff like that.
Not sure whatelse to try. Just give me file not found error on the player. I can’t see what the difference might be.


It’s difficult to say what the specific issue is… however, if you’re getting errors about it not being able to find the file, it sounds like there may be some Flowplayer config tweaking that needs to be done.

For example, you may want to double-check that the XMOOV_PATH_ROOT and XMOOV_PATH_FILES settings are correct.

If XMOOV_PATH_ROOT is set to “$_SERVER[‘DOCUMENT_ROOT’]”, you may want to try explicitly setting the path rather than relying on the variable, just to make sure it’s pointing where you expect.