Can't request let's encrypt wildcard certificate

When I try to request a let’s encrypt certificate for just repo.domain.tld, it fails and the the log output says it tried to fetch www.repo.domain.tld/_acmewhatever instead of repo.domain.tld/_acmewhatever. Also, in recent versions, I can no longer request wildcard certificates.

Trying to request a wildcard certificate

From the look of it, it seems to be a DNS issue. You need to set a few records there.
You could try to install certbot as a test and see if it works then (was posted from @Joe for a similar issue if I recall it correctly).

In Virtualmin > Server Configuration > SSL Certificate, check if the box ‘Domains associated with this server’ has two entries or one. If there are two entries, such as:


…then Virtualmin is working normally: it is seeking from Lets Encrypt a certificate for two domains, one with www and one without. Verification for the domain with www is failing, which is confirmed by the error message that you see, perhaps because the domain www.repo.domain.tld does not exist.

To get Virtualmin to ask Lets Encrypt for a certificate with just one domain, i.e. repo.domain.tld, you must enable the radio button captioned ‘Domain names listed here’ and enter in that box:


Let us know if that works.

1 Like

I have no idea what fixed it but it was probably a combination of resetting the default website for the ip and a reboot or two. In response to @calport, I was already manually setting the domains for the certificate. The only problem that I have now is I can not request a wildcard certificate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.