can't reach http://mysite:10000

Hi everybody

first of all sorry for my English.

I have a big problem.
i add a free ssl CA from that website www.starssl.com and everything was fine.
but my virtualmin control panel wasn’t taking the certificate, so i tried the option “COPY TO WEBMIN” but without any luck. so then i tried to do that in the webmin control panel in the configure webmin under ssl and i redirect to files with the right certificate.

With this certificate i need 4 files to config :

SSLCertificateFile /home//ssl.cret
SSLCertificateKeyFile /home/
/ssl.key
SSLCertificateChainFile /home/
/sub.class1.server.ca.pem
SSLCACertificateFile /home/
*/ca.pem

After i press save it said can’t write to pid or something like that,and form here i can’t accses my control panel
it tried to restart the service, it ask for the password for the ssl as it should and then i saw this message

“Faild to open SSL key /home/*****/ssl.key at /usr/libexec/webmin/miniserv.pl line 4205.”

everything else is working fine my websites are ok and so as the SSL.

You could try to edit the main config file of the Webmin mini-webserver, /etc/webmin/miniserv.conf, and change the line ssl=1 to ssl=0 and ssl_redirect=1 to ssl_redirect=0. Then restart Webmin. This should at least enable you to log in to Webmin again without SSL to do further testing.

Thanks that help

Now i am able to log in, will do some more testing and report back.

Update:

I copied the certificates and the keys to the original folder that wembin pointed to.
and re-enabled the ssl and now everything works now fine.

Thanks for the help.