Can't pass Virtualmin post-installation on AWS EC2 instance

Hi there, fellows!

I’ve been following this tutorial ( to install Sendy at an AWS EC2 instance but, no matter how many times I try I can’t pass Virtualmin post-installation, it collapses at step 13 ( with this error message, rendering the instance useless:

No ethernet interface could be automatically found on your system. Use the module configuration page to set the interface manually.

Any help would be highly appreciated.

@arlugones hi there and welcome to virtualmin forum, well I feel sorry that you feel frustrated about this whole thing, lets make you move very fast here… is not official virtualmin docs for how to install the stuff on aws… perhaps I would like you to follow official documentation how to install virtualmin on aws and if there is no such a documentation, this is an right place for you to advertise it. As your output from your terminal said: you should do : Use the module configuration page to set the interface manually. The message is telling you what you need to do in such an clear way. You should follow it till end.

Do what it’s telling you to do. :wink:

Virtualmin couldn’t detect the default network interface, so you need to tell it what it is in the Virtualmin configuration page (System Settings->Virtualmin Configuration->Networking Settings), and you’ll also need to set the IP, since AWS instances do not have a public IP configured on the device itself (it’ll have a private IP and a public one that’s routed to it via the AWS configuration).

1 Like

Soounds great but I’m a newbie :slight_smile: and there are quite options to “fill”… thought Virtualmin would do this automatically. I have an Elastic IP for my instance… Should I fill options with this?

You need to fill in the interface name and the IP.

Those options are labeled:

Network interface for virtual addresses

Default IP address for DNS records

I have no way to even guess the name of your network interface. You need to look at the output of ifconfig or ip ad sh to figure it out. It will be whatever the non-localhost interface is (the interface that is not 127.0.0.x).

Your Elastic IP goes in the IPv4 address field.