Can't Login at ALL

Ok I am having a serious issue that doesn’t make sense. Our of randomness I can not login as root. I tried changing my password via SSH, and using

I also changed the password of another user and couldn’t login with that user either. Ive rebooted webmin/virtualmin several times and have no login failure logs.

What it going on?

Hmm, that’s an odd issue!

What distro/version are you using?

And when you say you can’t login – do you mean you can’t login to Webmin/Virtualmin? Or you can’t login to any service on your server at all?

If you can’t login at all, how were you able to manage gaining access to change your password?


I am using debian squeeze (6). I can’t login to the WEB interface. I also tried “hacking” the webmin user/passwd files too with no success -_-…

The question that Eric asked is still valid/unanswered… I you cannot login as root, how could you change your password? IF you could log on somehow, is there any helpful stuff in the syslog and auth log? We need more details about what exactly you tried and what exactly doesn’t work.

UM as I said, I can SSH in b/c I a using a public/private key auth. So I tried changing the root password via the passwd command. There is no useful information in any logs about the login failure.

What does not work is logging into Webmin/Virtualmin via the web browser.

I’ll repeat. Using has no effect. Using passwd have no effect. If i change another webmin users password, that user can’t login still. using “virtualmin change-password” has no effect.

Okay, you didn’t say about key auth before, hence I asked.

If logging in to Webmin is the issue, and not SSH, you might want to check if Webmin uses Linux authentication for the users in question, or some other method.

It shouldn’t have changed. I haven’t changed how it auth’s users at all, so I assume its the factory settings. so-to-speak. I was able to previously login using root but now I can not.

Any ideas.

It shouldn’t have changed

Well, you also shouldn’t be having problems logging in as root – so something changed, we’ll just have to do some troubleshooting to figure out what that is :slight_smile:

Re-reading all your posts, I realize that it’s not clear whether you’re having this problem only with Webmin, or whether it’s also a problem with SSH and other services.

That is – when not using SSH key authentication, can you log in as root over SSH?

One way to test that would be to log into your server over SSH using the key auth, then just run “ssh localhost”, and see what happens when you attempt to login as root with a password.

Also, you said you were having this problem with one of your users – can that user log into, say, FTP?

The key is to figure out what parts aren’t working – and from there we can begin putting together what might be the cause of that.

The logs that may have useful information about this are /var/log/auth.log, and /var/webmin/miniserv.error.


I have tested the root. I did “su -l” to another user then did it again to access root to test the password. I also created a virtual server VIA CLI and tried logging in as that user via web with no success.

So it seems no webmin logins work at all.

Can you clarify the outcome of your testing – when you used SSH to access your root account, are you saying that you were successfully able to log in when using a password?

Meaning – the only problem you are having is with logging into Webmin, that your other services are working fine?

Are any logs at all generated in /var/webmin/miniserv.error when attempting to log into Webmin?

And what error is it that you see in your browser when attempting to log into Webmin?


Yes I could login as root via SSH.

Yes I believe only webmin is having the issue.

There are no logs created related to the login.

When I login, I just get a invalid login message. After several tries I get an IP block, then I have to restart webmin to unblock my IP.

Figured it out.

I accidentally changed the A record for my VPS address to the wrong server. I have a main server for a lot of sites then our hosting server. The main server holds the dns record for the hosting servers hostname. It got changed accidentally. So I was basically brute forcing my way into the wrong server :D.

A small thumb rule to others. Access the server via IP and not hostname when trouble shooting. It migt be common sense to some but I bet i am not the first or last to do this.

Okay, this could have taken a LONG time trying to figure this out for you. :stuck_out_tongue: I was about to suggest that your system got hacked and the logins changed.