Can't install Virtualmin - Hash Sum mismatch

I’m trying to install Virtualmin GPL on a Ubuntu 10.04.4 LTS. I downloaded the install.sh script, when I run it I get an error:

…Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/usermin-virtual-server-theme_6.8_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-security-updates_4.5_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-virtual-server-theme_9.0-2_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-virtualmin-awstats_5.1_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-virtualmin-dav_3.7_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-virtualmin-htpasswd_2.6_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-virtualmin-mailman_6.3_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/webmin-virtualmin-svn_5.1_all.deb Hash Sum mismatch
Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/main/binary-amd64/virtualmin-base_1.0-29_all.deb Hash Sum mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I saw other threads about this from a few months back, I assumed this has been fixed by now. Is this the same issue or something new? What needs to be done to correct it?

Howdy,

Unfortunately, Ubuntu 10.04 reached it’s EOL back in April.

That’s no longer supported by the folks at Ubuntu, or by Virtualmin.

I suspect the repository was broken a few months back when the other repos had a similar problem – but since Ubuntu 10.04 is no longer supported, Joe didn’t correct the issue for it.

Sorry! But that’s not likely to be working again.

Would it be possible to install a more current version of Ubuntu?

-Eric

No, I can’t upgrade any time soon.

Sorry, there’s not much we’re going to be able to do there… Virtualmin doesn’t have support for EOL’d distributions.

We’d definitely recommend against deploying a distribution that has security vulnerabilities that can’t be fixed.

That said, if you really need to put Virtualmin on Ubuntu 10.04, you can do so, but it would need to be done manually.

You can always use the manual installation process in order to get Virtualmin onto your server. It’s more work than the install.sh, but it would allow you to get Virtualmin up and running there.

-Eric

In recent post I explain the same problem on Debian 8.1

Failed to install script : Download of http://prdownloads.sourceforge.net/sourceforge/phpmyadmin/phpMyAdmin-4.4… failed : HTTP/1.1 404 Not Found

The url is wrong

Tony

Did you find a solution or a workaround to that issue?

I’d suggest opening a support request, using the Support link above. Then Jamie can work with you to correct the phpMyAdmin issue.

-Eric

Hi,

You mentioned you are not able to upgrade your Ubuntu install anytime soon, is there a particular reason for this?

If you require assistance making a smooth transition from your current version to a newer version supported, I’d be happy to lend my assistance on the task.

Drop me a line if you’re interested.

Best Regards, Peter Knowles TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com


Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!