can't get rid of default "it works page"

I’m really stuck on this one - I suspect I’m missing something simple…

I have two servers running Virtualmin: one that sits nicely inside a commercial VPS and works exactly how I want it to - its brilliant - thankyou Virtualmin, the other I decided to set up last week on an old computer at home since the one on the VPS works so well. I set up both from vanilla installs of ubuntu 12.04 server but I just cannot get the home server to display virtual host content despite it sitting there plain as day in /home/*/public_html/

All I get is the default “It Works” page. I can’t seem to get any directory aliases working and even the script installation of phpmyadmin results in a 404 not found response.

Since I set both up in the first place using the install script I suspect the issue centres around networking (?) because I don’t recall sorting out /etc/hosts and /etc/network/interface to get the FQDN set up for the VPS; I expect that was taken care of by my hosting company behind the scenes(?)

I’ve tried working through all the howtos and guides I can find but I seem to be going over my same footsteps now. As things stand I have my server tucked away behind NAT and with my router forwarding all typical ports. Virtualmin itself seems to be installed fine and hostname -f returns a FQDN.

The non IPv6 parts of /etc/hosts looks like: localhost
192.168.x.x name

Whilst /etc/networl/interface is like:

auto eth0
iface eth0 inet static
address 192.168.x.x
network 192.168.x.0
broadcast 192.168.x.255
gateway 192.168.x.1

Apart from that, I don’t think I’ve changed anything in virtualmin. All help and suggestions gratefully received :slight_smile:

So I think I just fixed this and it was indeed something simple.

During the Virtualmin Check that happens just after installation there was a suggestion pointing out that whilst my IP was configured to be 192.168.x.x it appears my actual IP was x.x.x.x, that this was normal if stuck behind NAT and that this could be changed in the appropriate module.

The way I read this message (and I’m sorry I haven’t quoted it word for word above), I understood it to mean that it was normal if behind NAT and that I should therefore make the change in the module forthwith.

The first time I ignored this message everything worked perfectly so I guess I should have read it as if you are behind NAT, leave this alone, if not you can make the appropriate change in such and such a module.

It didn’t come up in my original uninstall because of the the way my VPS is set up. Facepalm.

I just decided to start from a completely fresh slate with CentOS and when I check ed the message its not ambiguous at all and said I should change the ip…

“Default IP address is set to 192.168.x.x, but the detected external address is actually xxx.xx.xx.xx. This is typically the result of being behind a NAT firewall, and should be corrected on the module configuration page.”

So ignoring the message gives me a setup that seems to work so far but am I likely to be facing problems further down the line if I don’t deal with this properly?



That message means that you may want to go into System Settings -> Virtualmin Config -> Network Settings, and in there set “Default IP address for DNS records” to “Automatically detect external address”.


Nice one, thanks for letting me know :slight_smile: