Can't get postfix to lookup MX (stays local)

I have a domain that is using Google apps for MX

When POSTing a contact form, the e-mail stays local to the virtualmin server. I have e-mail disabled for the domain in virtualmin. I also have the MX records for Google apps in the DNS zone file local on the server.

Even with this setup, I cannot get the server to look outside itself for this domain.

Any help would be appreciated.


Well, I’d first triple-check that the “Mail for Domain” feature is disabled for that domain in Edit Virtual Server -> Enabled Features.

If it is, I’d check in /etc/postfix/virtual, and make sure your domain doesn’t show up in there at all.

If it does, you may need to delete it and run “postmap /etc/postfix/virtual” to compile the database.



Great that was it! it was still in there, which I had commented out earlier I just didn’t run the postmap command. I thought by restarting the postfix service it would reload the config files.

Great help!