can't enable Apache SSL website

Virtualmin version 6.04

the website home directory is
however, when trying to enable SSL, I get the message:
Creating SSL certificate and private key …
… SSL website failed! : Failed to open /home/MyDomain/public_html/fe/public/fe/ssl.cert.webmintmp.17675 : No such file or directory at …/ line 1478, line 1.
I tried to create that extra /fe/ folder /dunno why SSL creation ould suggestthat folder but well…

So I got this error message:
… SSL website failed! : Failed to open /home/MyDomain/public_html/fe/public/fe/ssl.cert.webmintmp.18082 : Permission denied at …/ line 1478, line 1
Hwever, I noticed that it created there two files, ssl.key.lock and ssl.cert.lock.

Any ideas on how to solve this?

Check the ownership of the folders and files in that directory. Make sure the ownership and permissions are correct.

Who are you logged in as when you manually created directory?

Thanks for your reply. It solved > I had created that “extra fe” folder as root (as I thought Virtualmin would work as root) . Now I changed ownership to the MyDomain user and works.
Still something is upsetting me. Why is virtualmin adding this “fe extra” folder? Where can I set that. I think the normal thing would be to have the
ssl.cert and ssl.key
in /home/MyDomain/public_html/fe/public/
and not in /home/MyDomain/public_html/fe/public/fe

See also for other Forum readers the main cause of this in Troubleshooting topic

This i don’t know sorry
in /home/MyDomain/public_html/fe/public/
and not in /home/MyDomain/public_html/fe/public/fe