Can't Delete Virtual Server

Hi, currently i’m using Webmin and i have problem.

I have created my first virtual server, lets says its Then, when i want created to second domain (, yes its success also. But my second domain not showed up on virtual private server… I try to create new virtual server using my second domain, but it says “Failed to create virtual server : The domain is already hosted by your Apache webserver”
How to delete it? Its not showed up op dropdown list!! Really depressed!

I have try to look in /etc/webmin/virtual-server folder… But only has in that folder.

Can’t delete virtual server, can’t create virtual server anymore…

Please help me… Really appreciated it!

Sorry for bad english.


It’s possible that the record for is still in Apache.

What Linux distribution are you using?



I’m using CentOS 6 64 Bit


Okay, if you look in /etc/httpd/conf/httpd.conf, do you see a VirtualHost block that contains the name “” in it?


Hi, yes the file contains

I delete:

SuexecUserGroup "#501" "#501" ServerName ServerAlias ServerAlias ServerAlias DocumentRoot /home/domain2/public_html ErrorLog /var/log/virtualmin/domain2_error_log CustomLog /var/log/virtualmin/domain2_access_log combined ScriptAlias /cgi-bin/ /home/domain2/cgi-bin/ DirectoryIndex index.html index.htm index.php index.php4 index.php5 Options -Indexes +IncludesNOEXEC +FollowSymLinks allow from all AllowOverride All allow from all RewriteEngine on RewriteCond %{HTTP_HOST} RewriteRule ^(.*) https://domain2:20000/ [R] RewriteCond %{HTTP_HOST} RewriteRule ^(.*) [R]

And when i try to create in my virtualmin panel, it says “Failed to create virtual server : The specified administration user already exists


Yeah, it sounds like when it was attempting to delete that Virtual Server, that the process was somehow either interrupted, or there was an error of some kind that stopped it in the middle.

So, you may need to manually remove some things to get that corrected… and you’ll know what to remove by the error messages you get.

In this case, it sounds like it’s saying the username still exists… so you’d want to delete that user.

You can do that from the command line, or from Webmin -> System -> Users and Groups.

You may also want to look at Webmin -> Webmin -> Webmin Users, and make sure the Webmin user has been deleted.


Many problems with this it looks and no solutions to any of them.

I run Debian 8 - with webmin and virtualmin tried to run nginx but it made problems there was no solutions to.
One of them was execution of php however i could not use any of the solutions suggested, so activated apache again and a lot of other problems came up.

Minor i guess i decided to create virtual hosts for my system and had a working domain setup and after finishing setup of the virtual hosts the domain was not to find again my guess is that it was in /home/admin/public_html and i want it in /var/www/html/domain.tld/public_html#

And as such it is defined in the .conf file created

The Virtualmin has nothing created to change this small thing as far as i can see so how do i solve it i have moved all files from old location to new location but when go to the domain.tld it says can not be found and i can’t just delete the virtual host from withing virtualmin to create a new and specify the new location.

Wonder why

Look forward to hear a solution maybe just a link in shell can do it i am newbie in Linux and virtualmin

Found a solution :