can't change VM port or password in CloudMin anymore


I noticed that I can’t change a Virtual Machine’s SSH or webmin port, or password in CloudMin anymore.

Some time ago (I think it was prior to version 5.9?) I could change a Virtual Machine’s SSH port in CloudMin - i.e. when a user changed their XEN VM’s SSH port, I could tell CloudMin what the new port was, but now I can’t do that anymore

This used to be in CloudMin > {select server, or VM on the dropdown menu} > “Edit System” > “Authentication”.

Why was this option taken away?

I believe what you are looking for is in the left column under: Change Password ?
As for the Port, I cant find it either…

Yes, those 2 options used to be together but I need to change the SSH & Webmin ports in Cloudmin. How do I do this?

I cant find that option either, per haps a bug report or feature request would be in order?

Well, I was hoping to get one of the CloudMin devs / support guys input on this matter first. Maybe they have a good reason why it isn’t there anymore, and have relocated the function altogether.

Can anyone PLEASE tell me to how change a VM’s SSH port in the CloudMin interface? A client changed their SSH port and now we can’t add a new network interface or upgrade the RAM without taking down the VM first.


I’m not sure how to do that either, unfortunately… I’d suggest going with Ronald’s advice above, and popping a note regarding that into the support tracker, which you can do using the Support link above.

Then Jamie can work with you regarding how to change the SSH port, or whether it’s a feature that needs to be added.



  • Go into the Webmin of your system.
  • Go to Webmin - Webmin Configuration - Ports and Addresses.
  • Change the bound port from 10000 to something else.
  • You might also want to change the broadcast port; I think it’s used for automatic system detection from other installations, through them sending a UDP broadcast query on port 10k. You want stealth so change that too.
  • Go to Webmin - Usermin Configuration - Ports and Addresses.
  • Change the bound port from 20000 to something else.
  • Go back to the Cloudmin manager.
  • Select your system in Cloudmin.
  • Click on Change Password.
  • Click on Change login used by Cloudmin (it’s in the top right corner of the box).
  • Set your new Webmin port there.
  • Click Change Now. This will refresh the system status as well and may take a few minutes.
  • Next up, you should change the Webmin root-password on the system. Even if you used SSH key-based logins, you must set a strong root Webmin password as well so that nobody can brute-force log in via the Webmin panel either, since the Webmin panel gives users root access too.
  • Go back to the the Change Password panel.
  • Next, click Change login used by Cloudmin.
  • If you are using password-based SSH, then change “Authentication for root SSH login” to “Set password” and write a new password there. Set “Webmin password for root” to “Same as SSH”
  • If you are using key-file based SSH, then keep “Authentication for root SSH login” set to “Use SSH Key”. Set “Webmin password for root” to “Set password” and write a new password there.
  • Click Change Now. This will take a while. Be patient and wait until it says that both SSH and Webmin passwords have been updated, and then wait for it to refresh the system status…
  • If you are using key-file based SSH, you NEED to go into your server’s Webmin panel, and under Servers - SSH Servers - Authentication, you should disable “Allow authentication by password” and enable “Allow RSA/DSA authentication” so that ONLY certificates are allowed over SSH. Be very sure that your root user certificate has already been set up in Cloudmin and Webmin before doing this, though, otherwise Webmin can’t log back in either. Then click Save, followed by Apply Changes.
  • Alright, you’re good to go! Much more secure now that random portscanning retards won’t find your system on port 10000 like everybody else, and even if they do find it, they won’t be able to login with a simple autogenerated root password like “dhwadhy” (which Virtualmin uses for root by default if you chose SSH key-file based logins).
  • Using key-file based (public key crypto) SSH logins is not required if you use really strong passwords for ALL accounts, like “6AKupBM9wTPYQM” (obviously DON’T use this one that I just posted!), and users will probably appreciate not having to store a keyfile. Just be sure that not a single login-capable account is left with a weak password.


If you’re trying to change the port number of a “host” machine in Cloudmin, it’s done through:

Webmin > Webmin > Webmin Server Index

*** make sure to click “edit” next to the name of the server you wish to edit ***

Best Regards, Peter Knowles TPN Solutions

P: 604-782-9342

Hi TPN Solutions,

That’s not really correct, but useful information nonetheless. The Cloudmin host computer’s Webmin: Webmin: Webmin Server Index is just a list of all existing registered servers.

Sure, you can go there and click “Edit” to change the port, which is useful in case your system is offline and doesn’t have the “Change Password” option I mentioned above. However, you can’t change the used port from there. That must be done on the actual system using my instructions.

To everyone reading: Follow my bulleted step by step list above for the exact instructions for changing a server’s existing port. TPN Solutions answer helps if you can’t find the “Change Password” option (such as if Cloudmin has no connection to the server, or if the server is down).


Gotcha, misread the post. Sorry bout that.

Best Regards, Peter Knowles TPN Solutions

P: 604-782-9342