Can't add Git repositories, no menu option?

I’ve installed git, gitweb and the webmin git module.
I then enabled the git module through plugins & features.
After that I enabled git repositories on one of my virtual hosts, saved the config and visited and got the gitweb interface - so far so good.

However, short of doing it myself on the command line, I can’t add new repos using the virtualmin menus. This article says I should see a ‘Git Repositories’ option under ‘Services’ but I don’t see it:

I’ve tried this on two seperate and very different virtualmin servers, one running Ubuntu 12 and one running CentOS 6.

Have I dont something wrong or is the documentation out of date?


So just to verify – you’re saying that in Edit Virtual Server -> Enabled Features, that “Allow Git repositories?” is set to “Yes”?

Once that is set, there should be a Services -> Git Repositories option available.

If you aren’t seeing that – can you clarify how you added the git module?

Did you install it via apt or yum?


Hi Eric,

thanks for your reply.

Yes that’s correct.
I’ve done this on both servers, and even tried restarting apache and webmin but no dice. The Services -> Git Repositories link doesn’t show.

I installed git from the repos, via

yum install git gitweb

or in the case of the ubuntu server,

sudo apt-get install git gitweb

This went through fine.
Then I went to webmin -> virtualmin package updates and ticked the webmin-virtualmin-git package and installed it. When I check back on that page under ‘Everything’, it is listed as running latest version 1.4.

After doing this, the ‘Allow Git Repositories?’ option showed up fine on the edit page for the virtual servers, but after enabling it I didn’t see the link under Services.

I could wipe out both git and the module and reinstall from scratch if you think that will help?

Another interesting point is that if I go to, I see the gitweb interface and it seems to be working although obviously it has no repositories listed. I wonder if this is just a display bug in Virtualmin as the system aspects seem to be there?


Just wondering if this was ever resolved? I have got the same issue. I installed in the same way.

Additionally, when I go to System settings > Features and plugins and I try to open the module I get

Access denied : User MYUSER is not allowed to use the Virtualmin Git Repositories module

I’ve been to Webmin > Webmin users and given myself permission, but that hasn’t resolved anything.

Just wondering what the next steps might be?

Thanks in advance

So 15 months later and after abandoning running Git through Virtualmin, I’ve found myself needing it again.

This is mostly a bump as I’ve no new information to add, other than I’ve tried the install process detailed here: in both Ubuntu 12.04 and Centos 6.5 today, with the same result - to clarify, the page under Services -> Git Repositories does not appear in the menu.

They are infact the exact same servers I’ve tried to install on before, however they have both had many configuration changes and software updates, and are both up to date with the latest Virtualmin and Git packages.

Does anyone have any new information on how to go about getting this working?