Can't access Virtualmin remotely

I am unable to access Virtualmin from any other computers except the box it is running on.

when I enter : https://server.mydomain.com into the browser I get an error that it can not locate the server. The couple sites I have however are all working…it is just accessing the login remotely that is the problem.

I was able to do this previously. One thing I did that may have caused the problem was I deleted the virtual server mydomain.com and recreated it. I never set up virtualmin myself initially (I had someone else do it) and I am wondering if there was a special setting (dns or something) for this domain that has to be created for the login to work remotely.

Any ideas where I should look.

use the IP and add the port :10000

https://123456789:10000 or use any other domain hosted on that server
https://anyotherdomain:10000

Thanks for the reply. Yes actually I forgot to add the :10000 in my original post.

I did just try it with other sites hosted and it worked.

I also did it with the original site as mentioned :
https://mydomain.com:10000 <-- this worked
https://server.mydomain.com:10000 <-- using the fully qualified domain name did not work…but this is how I used to always do it.

As long as it works is all that really counts…I am still curious why using the FQDN does not though.

thanks

Howdy,

The DNS zone file may be missing the entry for server.mydomain.com. By default, Virtualmin would create www.domain.com, domain.com, mail.domain.com, and some others, but it might not add server.domain.com without you telling it to.

You could go into Services -> DNS Domain for that particular domain to see if there’s a record for your server’s FQDN.
-Eric