Can't access Virtiualmin / Webmin after it was working

Hi

Going to https://serverip:10000 or the like brings back nothing it;s as if server is unresponsive.

I’ve done follwoing

  1. Checked webmin service is running
  2. Checked IPTables have port 10000 open
  3. Checked minisever.error - had something about PAM but that was there from when it was working too but i installed whatever was needed to fix that

The only thing we did on day it stopped working was Viritualmin was showing some update scripts so i ran updates and we added a 2nd virtual ip address.

apache, mysql all seem to be working fine. I’m just lost as to where to look or what to do very strange

Server is Centos 6.6 and webmin / virtiualmin been running fine for month recently we had ddos as part of that we added the secondary ip address

On same day stopped working

Anyway now we on a whole load of new ip’s above services work but not viritualmin do i need to tell it of the new ip addresses somewhere

As i also get slow sites if i edit the hostname to something new but if i revert back to what was originally set everything seems fine

i mean i did edit both hosts and HOSTNAME . As i’m not linux guru i thought must be referenced somewhere else and i’m thinking same with ip’s

Thanks

Nadeem

Howdy,

Are you able to access your server via SSH?

If so, can you login via SSH, and telnet to port 10000?

I’m curious what happens when trying to access that port via telnet from within your server.

-Eric

Hi

I’ve very novice at these things, 1st i had to work out how to install telnet

i was not sure which command to run so i ran

telnet x.x.x.x 10000

which gave

Trying x.x.x.x…
Connected to x.x.x.x.

Tried to copy above bit and then i got below

telnet x.x.x.x 10000
Trying x.x.x.x…
Connected to x.x.x.x.
HTTP/1.0 200 Document follows
Server: MiniServ/1.710
Date: Tue, 4 Nov 2014 07:23:39 GMT
Content-type: text/html; Charset=iso-8859-1
Connection: close

Error - Document follows

This web server is running in SSL mode. Try the URL https://x-x-x-x.static.as29550.net:                                                10000/ instead.

i also get

Connection closed by foreign host.

Thanks

Howdy,

It appears that Webmin is available when accessing it from your server… something may be blocking access to port 10000 remotely. That could be a firewall running on your server, or possibly something in front of your server.

What is the output of these two commands:

netstat -anlp | grep :10000 iptables -L -n

Netstat

tcp 0 0 0.0.0.0:10000 0.0.0.0:* LIST EN 1505/perl
udp 0 0 0.0.0.0:10000 0.0.0.0:* 1505/perl

the iptables command returns a massive list as i have CSF firewall running but i know on that 10000 is open

So i stopped it and ran the command and i got

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Which may or may not help

Sorry we do have Cloudflare but i’m not going via url but rather by ip which bypasses cloudflare then

I have the same problem on GCP Debian. After doing update from webmin I was not able to access serverIP:10000. It seems somthing has closed port 10000 as I cannot reach it from outside. sudo netstat -anlp | grep :10000 gives me
udp 0 0 0.0.0.0:10000 0.0.0.0:*
17419/perl
udp 0 0 0.0.0.0:10000 0.0.0.0:*
12858/perl
But on my instance firewall rules tcp is open. Any help?

with regard to Google Cloud Platform, you do realise that there are two firewalls…1 for the google cloud network and 1 for the instance itself?
you need to go into your google cloud network and make sure that firewall rules in that interface are also setup so port 10000 is open.

The network firewall rules are found in Google Cloud Dashboard> VPC Network > firewall rules

if you are running on the Google Cloud App Engine, firewall rules are found under the appengine dashboard itself (which is a bit inconsistent to be honest)

Thanks Adam,
The problem was I think, that after reboot (after updateing) I lost all my iptables rules.
I installed :apt-get install iptables-persistent (after inserting the 10000 rule) and rebooted and all is well.

I added webmin rule in Google Cloud Dashboard> VPC Network > firewall rules already. Actually it worked normally many days before. However, today I cannot access webmin.

sudo netstat -anlp | grep :10000

tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 1288/perl
tcp6 0 0 :::10000 :::* LISTEN 1288/perl
udp 0 0 0.0.0.0:10000 0.0.0.0:* 1288/perl