Can't access to Virtualmin Interface

Hi all,

I have problem accessing to Virtualmin. A few days ago when I tried to upgrade to the new GPL upgrade, all the list items under Webmin tab was gone. I thought restart would help then too and restarted the server but no help.

Since yesterday I can not access to Virtualmin interface. Neither port 10000, nor 20000 opens. Through Virtuozzo Power Panel, I restarted the server thinking the problem might be solved. I also restarted the webmin service over SSH but none of prior methods helped.

Any help is highly appreciated.

Best Regards

After restarting Webmin “/etc/init.d/webmin restart”, are you seeing any errors in /var/webmin/miniserv.error?


Hi, Andreychek.

Thanks for replying.

I see the below error when checking the file you mention:
Perl module Authen::PAM needed for PAM is not installed : Can’t locate Authen/ in @INC (@INC contains: /usr/libexec/webmin /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at (eval 17) line 1.
BEGIN failed–compilation aborted at (eval 17) line 1.

Might it be because of the perl upgrade which happened a few days ago? All the sites are working normally though.

I have googled and found among Virtualmin old posts similar problem and on that post you indicated that the firewall might cause the problem. I have csf installed for a long time and it has been working normally. Reading the post, I’ve stopped csf and the problem was solved. However, when starting csf again the 10000 port goes away.

I have edited csf.conf file and added 100000 to allowed ports list and restarted the firewall. Now virtualmin is accessable but when I click on Webmin link, I don’t see all the menus under Webmin tab. What I see is Servers block and Virtualmin Virtual Servers (GPL) under it.

No one knows how to solve the problem? I’m stuck with it and can’t make it work. Will anybody help me please?