cannot use IMAP on devices

cannot connect to IMAP.

i have everything setup without tweaking. my email send/receive works fine on roundcube, but i cannot access my IMAP via phone or other devices.

Howdy,

What error do you get when trying to access IMAP from your various devices?

If you look in your email logs, do you see any errors when your devices attempt to connect?

-Eric

take a quick look at your /etc/postfix/master.cf and make sure the SMTP stuff is uncommented.

mine looks like this

. . .

==========================================================================

service type private unpriv chroot wakeup maxproc command + args

(yes) (yes) (yes) (never) (100)

==========================================================================

smtp inet n - - - - smtpd -o smtpd_sasl_aut$
#smtp inet n - - - 1 postscreen
#smtpd pass - - - - - smtpd
#dnsblog unix - - - - 0 dnsblog
#tlsproxy unix - - - - 0 tlsproxy
submission inet n - - - - smtpd
-o syslog_name=postfix/submission
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject

-o milter_macro_daemon_name=ORIGINATING

smtps inet n - - - - smtpd
-o syslog_name=postfix/smtps
-o smtpd_tls_wrappermode=yes
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject

-o milter_macro_daemon_name=ORIGINATING

. . .

i figured out that SSL works, but non ssl doesnt.

i really want 143 incoming IMAP and 26 outgoing IMAP for no SSL. i dont have a cert anyway.

so the IMAP does work, but not without SSL. weird.

for some reason 143 is working, but now i cannot get non ssl outgoing mail.

i would like port 26 for outgoing IMAP non-ssl. how would i accomplish this?