Cannot upload .htaccess file and www domain is not loading

Hello,

I’m new to Virtualmin and Linux system.
I installed Virtualmin but I have some problems:

  • My website loads fine when visit: http://mywebsite.com
    but does not load when visit: http://www.mywebsite.com
    (I added a CNAME record www to vps IP address)

  • I can not upload .htaccess file. File disappears after finished upload.

Please help me!

Howdy,

Well, files wouldn’t disappear when uploaded… I have that your client isn’t displaying it, as files beginning with a “.” on Linux are considered “hidden files”.

As far as the ‘www’ issue goes – Virtualmin automatically adds a ‘www’ alias anytime a domain is added to the system. If it’s not working for you, that may imply you’re not using your Virtualmin server as a DNS server. Is your DNS being hosted at a third party? If so, you would need to add the ‘www’ CNAME at your DNS provider.

-Eric

Yes, I do not use Virtualmin server as a DNS server. How to do that?

There’s nothing wrong with using a third party DNS server… it just means that you have to add each DNS entry to it.

If you want to use your VIrtualmin server as your DNS server, you can check out the section “How do I setup nameservers for my server?” in this document:

http://www.virtualmin.com/documentation/dns/faq

And how to make .htaccess file appear ?

Well, it’s your client that’s hiding it… so how to make it appear is dependent on what client you’re using :slight_smile:

You’d need to find the setting in your client that’s set to not display hidden files, and you’d need to tweak that to display all files.

-Eric

  • Yes, I do not use Virtualmin server as a DNS server. How to do that?

  • And how to make .htaccess file appear ? ( When I upload .htaccess file to hosting with Cpanel, the file appear. I use CuteFTP Professional to upload files )

Thanks.

Ok. Now I can see hidden files and .htaccess appeared.
Thank you.

Could you guide me how to use Virtualmin server as a DNS server?

Could you guide me how to use Virtualmin server as a DNS server?

Oops, do to a typo, my link to the DNS documentation didn’t show up. You should be able to see that now in my above comment.

-Eric

Thanks!
I will try.

Please see the screenshot attachment.
Is this correct?

Sure, it looks like for one of your Virtual Servers, you’ve added two DNS ‘A’ records – ns1 and ns2. Those records appear to be added correctly.

-Eric

Thank you for helping me.

But I have a new problem.

I already selected cp1251 when created database:
Character set for new database: cp1251; Collation order for new database: cp1251_general_ci

But Encoding still is UTF-8 ( Please see the screenshot attachment )

How to change Encoding from “UTF-8” to “windows-1251” ?

Howdy!

I’d suggest opening a new forum thread for your new topic… we get confused easily around here, and having too many topics in one forum thread is one of the many ways to confuse us :slight_smile:

Thanks!

-Eric