Cannot Update HTTP - Perl Path Issues

This morning I had 4 “install failed!” when updating via Virtualmin. Other updates went thru fine.

[code]yum -y install httpd …
Error: Package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64 (virtualmin)
Requires: /usr/local/bin/perl

yum -y install httpd-devel …
Error: Package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64 (virtualmin)
Requires: /usr/local/bin/perl

yum -y install httpd-tools …
Error: Package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64 (virtualmin)
Requires: /usr/local/bin/perl

yum -y install mod_ssl …
Error: Package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64 (virtualmin)
Requires: /usr/local/bin/perl

whereis perl
perl: /usr/bin/perl /usr/share/man/man1/perl.1.gz[/code]

CentOS 6.4x64
Virtualmin 3.99.gpl
Webmin 1.620

seems the latest httpd-devel package has incorrectly got a dependency of /usr/local/bin/perl

creating a symlink to /usr/bin/perl doesn’t help. Can this be fixed ?

Operating system CentOS Linux 6.4

Webmin version 1.620

Virtualmin version 3.99.gpl GPL

Same problem here, Centos 6

Setting up Update Process
Resolving Dependencies
–> Running transaction check
—> Package httpd.x86_64 1:2.2.15-15.el6.vm.1 will be updated
—> Package httpd.x86_64 1:2.2.15-28.el6.vm.1 will be an update
—> Package httpd-devel.x86_64 1:2.2.15-15.el6.vm.1 will be updated
—> Package httpd-devel.x86_64 1:2.2.15-28.el6.vm.1 will be an update
–> Processing Dependency: /usr/local/bin/perl for package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64
—> Package httpd-tools.x86_64 1:2.2.15-15.el6.vm.1 will be updated
—> Package httpd-tools.x86_64 1:2.2.15-28.el6.vm.1 will be an update
—> Package mod_ssl.x86_64 2:2.2.15-15.el6.vm.1 will be updated
—> Package mod_ssl.x86_64 2:2.2.15-28.el6.vm.1 will be an update
–> Processing Dependency: /usr/local/bin/perl for package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64
–> Finished Dependency Resolution
Error: Package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64 (virtualmin)
Requires: /usr/local/bin/perl
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Tried to update from Virtualmin and from command line all without success.

 yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.einstein.yu.edu
 * extras: mirrors.seas.harvard.edu
 * updates: mirrors.greenmountainaccess.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 1:2.2.15-15.el6.vm.1 will be updated
---> Package httpd.x86_64 1:2.2.15-28.el6.vm.1 will be an update
---> Package httpd-devel.x86_64 1:2.2.15-15.el6.vm.1 will be updated
---> Package httpd-devel.x86_64 1:2.2.15-28.el6.vm.1 will be an update
--> Processing Dependency: /usr/local/bin/perl for package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64
---> Package httpd-tools.x86_64 1:2.2.15-15.el6.vm.1 will be updated
---> Package httpd-tools.x86_64 1:2.2.15-28.el6.vm.1 will be an update
---> Package kernel.x86_64 0:2.6.32-358.6.2.el6 will be installed
---> Package kernel-devel.x86_64 0:2.6.32-358.6.2.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-358.6.1.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-358.6.2.el6 will be an update
---> Package kernel-headers.x86_64 0:2.6.32-358.6.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-358.6.2.el6 will be an update
---> Package mod_ssl.x86_64 2:2.2.15-15.el6.vm.1 will be updated
---> Package mod_ssl.x86_64 2:2.2.15-28.el6.vm.1 will be an update
--> Processing Dependency: /usr/local/bin/perl for package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64
--> Finished Dependency Resolution
Error: Package: 1:httpd-devel-2.2.15-28.el6.vm.1.x86_64 (virtualmin)
           Requires: /usr/local/bin/perl
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
libblkid-2.17.2-12.9.el6_4.3.x86_64 is a duplicate with libblkid-2.17.2-12.9.el6_4.2.x86_64
libuuid-2.17.2-12.9.el6_4.3.x86_64 is a duplicate with libuuid-2.17.2-12.9.el6_4.2.x86_64
4:perl-libs-5.10.1-130.el6_4.x86_64 has missing requires of perl = ('4', '5.10.1', '130.el6_4')
4:perl-libs-5.10.1-131.el6_4.x86_64 is a duplicate with 4:perl-libs-5.10.1-130.el6_4.x86_64
util-linux-ng-2.17.2-12.9.el6_4.3.x86_64 is a duplicate with util-linux-ng-2.17.2-12.9.el6_4.2.x86_64

Yes, same as you guys on CentOs 6.4 64.

Howdy,

Sorry about that error, Joe will be publishing a fix here shortly.

In the meantime, you can get around it by removing httpd-devel, which most folks don’t require.

There’s a bug report open for that here:

https://www.virtualmin.com/node/27359

How long until this issue is resolved?

That bug link goes to an access denied page.

This is corrected now, though you may first need to run “yum clean all” in order to clear out the incorrect dependency check.

All good here, thanks for the quick fix guys :slight_smile:

Transaction Summary

Upgrade 8 Package(s)

Total download size: 37 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): awstats-7.0-3.el6.noarch.rpm | 1.2 MB 00:00
(2/8): httpd-2.2.15-28.el6.vm.2.x86_64.rpm | 3.1 MB 00:03
(3/8): httpd-devel-2.2.15-28.el6.vm.2.x86_64.rpm | 157 kB 00:00
(4/8): httpd-tools-2.2.15-28.el6.vm.2.x86_64.rpm | 129 kB 00:00
(5/8): kernel-headers-2.6.32-358.6.2.el6.x86_64.rpm | 2.3 MB 00:00
(6/8): mod_ssl-2.2.15-28.el6.vm.2.x86_64.rpm | 398 kB 00:01
(7/8): usermin-1.550-1.noarch.rpm | 8.9 MB 00:06
(8/8): webmin-1.630-1.noarch.rpm | 21 MB 00:11

Total 1.4 MB/s | 37 MB 00:26

Thank you so much! Now the issue is solved :slight_smile: