Cannot send mail from remote client (or even connect?)

I’ve been able to set up IMAP mail retrieval and I don’t have any problems retrieving email from the server at the moment. However, I cannot get out mail to work. I’ve been playing with it for several hours now and what seems to be the most basic roadblock is that my mail.log doesn’t show any smtp connection attempts. It shows IMAP logins and mail sent from the server, but no log entries for when I’m trying to connect.


Ubuntu 8.04, Postfix, trying to connect using Apple Mail.


Do you get any errors in Apple Mail whenever trying to send a message?

A lot of ISP’s block port 25 – is it possible that’s the case in your situation?

One thing you could try is to have it connect to port 587 using SSL/TLS, rather than port 25.


Eric helped me figure this one out on the IRC channel (…&channels=virtualmin&prompt=1).

First problem we were having was connecting to the server. My client had port 25 (default for SMTP) blocked. So we tried port 587 (SMTPS) but that also didn’t get to the server. I needed to edit the master.conf file for Postfix and uncomment the sections beginning with “submission” and “smtps”.

After that I was able to connect to the server, but I was still having trouble authenticating. That was solved by giving postfix permission to sasl with the following two commands:

usermod -a -G sasl postfix /etc/init.d/saslauthd restart

And that was it. Hope this helps others!