Cannot save number of maximum sub-processes

SYSTEM INFORMATION
OS type and version CentOS 7.9.2009
Webmin version 2.001
Virtualmin version 7.2
Related packages SUGGESTED

Hi,

I entered 2 under “PHP service maximum sub-processes” then clicked “save”; however, it goes back to 5 on its own.

Is there another way to set this?

Thanks!

Hello,

This is a known issue which is going to be fixed in the next Virtualmin release.

Yes, you can manually edit PHP-FPM poll file in example.com - Services ⇾ PHP-FPM Configuration: Edit Configuration Manually page.

An option that you are looking for is pm.max_children (which you’re trying to change to 2). In order to change this option properly, correspondent option pm.max_spare_servers should also be set to not higher than 2.