Cannot receive Emails on fresh install

SYSTEM INFORMATION
OS type and version: REQUIRED
Centos 7.9
Webmin version: REQUIRED
Webmin version 1.979
Virtualmin version: REQUIRED
Virtualmin version 6.16
Related products version: RECOMMENDED

I’ve tried everything and I’m at the end of the rope here. I even bought a new server and did a totally new install with a totally different domain. Not sure whats up with webmin/virtualmin setup but out the box I cannot receive emails (I am testing sends from my gmail account)

  • I changed the A and MX records in the domain registrar and that didnt work (checked on intodns.com and everything looks fine)

  • I took suggestions editing /etc/postfix/main.cf (any right way for settings here?)

*I tried to leave the defaults for the most part but something is wrong even on a fresh install

I am getting the following errors from google

Postfix SMTP server: errors from google.com

Transcript of session follows.

 Out: 220 my.domain.com ESMTP Postfix
 In:  EHLO mail-wr1-f48.google.com
 Out: 250-my.domain.com
 Out: 250-PIPELINING
 Out: 250-SIZE 10240000
 Out: 250-VRFY
 Out: 250-ETRN
 Out: 250-STARTTLS
 Out: 250-AUTH PLAIN LOGIN
 Out: 250-AUTH=PLAIN LOGIN
 Out: 250-ENHANCEDSTATUSCODES
 Out: 250-8BITMIME
 Out: 250 DSN
 In:  STARTTLS
 Out: 454 4.7.0 TLS not available due to local problem

Session aborted, reason: lost connection

I see the following errors in /var/log/maillog

Aug 12 23:15:41 server1 postfix/smtpd[27665]: warning: No server certs available. TLS won't be enabled
Aug 12 23:15:41 server1 postfix/smtpd[27665]: connect from mail-wr1-f44.google.com[209.85.221.44]
Aug 12 23:15:41 server1  postfix/smtpd[27665]: lost connection after STARTTLS from mail-wr1-f44.google.com[209.85.221.44]
Aug 12 23:15:41 server1 postfix/cleanup[27668]: ABD777C13: message-id=<20210813031541.ABD777C13@my.domain.com>
Aug 12 23:15:41 server1 postfix/qmgr[23329]: ABD777C13: from=<double-bounce@my.domain.com>, size=922, nrcpt=1 (queue active)
Aug 12 23:15:41 server1 postfix/smtpd[27665]: disconnect from mail-wr1-f44.google.com[209.85.221.44]

I see additional errors in /var/log/maillog

Aug 12 23:24:34 server1 postfix/smtpd[28347]: warning: unknown[45.133.1.252]: SASL LOGIN authentication failed: authentication failure
Aug 12 23:24:34 server1 postfix/smtpd[28347]: lost connection after AUTH from unknown[45.133.1.252]
Aug 12 23:24:34 server1 postfix/smtpd[28347]: disconnect from unknown[45.133.1.252]
Aug 12 23:25:41 server1 postfix/anvil[27667]: statistics: max connection rate 1/60s for (smtp:209.85.221.44) at Aug 12 23:15:41
Aug 12 23:25:41 server1 postfix/anvil[27667]: statistics: max connection count 1 for (smtp:209.85.221.44) at Aug 12 23:15:41
Aug 12 23:25:41 server1 postfix/anvil[27667]: statistics: max cache size 4 at Aug 12 23:23:12


Hi,

It looks that you Postfix SSL certificate is not configured. Have a look at default-virtual-server.name - Server Configuration ⇾ SSL Certificate page and its Service Certificate tab.

1 Like

Have you tried installing SSL certs on Postfix, Dovecot?.

Hello, I came across another post and fixed it on one server. for some reason the original server with the issue is not working the same way. I suspect the issue is with the SMTP. I cannot receive new emails.

When I go to Email Client Settings on any virtual server I get similar to the following. For example

SMTP server hostname	mail.subdomain.domain.com
SMTP server port	25
Use SSL for SMTP?	No
SMTP password encryption type	Plaintext
SMTP encryption type	Unencrypted
type or paste code here

But on the server that works it is.

SMTP server hostname 	mail.subdomain.domain.com
SMTP server port 	587
Use SSL for SMTP? 	Yes
SMTP password encryption type 	Plaintext
SMTP encryption type 	STARTTLS

For some reason I cannot change the server port to 587 through Virtualmin/Webmin. I looked at Virtualmin >> (domain choosen) >> Server Configuration >> SSL certificate

I “copied to dovecot” on the server that’s not working properly but didnt have to on the one that works correctly.

How do I change the SMTP settings and fix this?

Hello? Can anyone tell me how to change the SMTP port to 587 and be secure?

I figured out how to change the port to 587 through the master config file for postfix. But my problem still persists and I cannot receive emails to the inbox. I checked the maillog and see the following

Sep  8 15:21:24 servername postfix/smtpd[599]: warning: unknown[00.00.0.00]: SASL LOGIN authentication failed: authentication failure
Sep  8 15:21:24 servername postfix/smtpd[599]: disconnect from unknown[00.00.0.00]

I am seeing

status=bounced (mail for mydomain.com loops back to myself)