Cannot log in to new virtualmin installation

SYSTEM INFORMATION
OS type and version Ubuntu 24.04
Virtualmin version 7.4.0

I installed Virtualmin on a Hetzner could VPS with a clean Ubuntu 24.04 LTS, doing only apt update, apt upgrade, reboot, then:
root@ubuntu-4gb:~# sudo sh -c “$(curl -fsSL https://software.virtualmin.com/gpl/scripts/virtualmin-install.sh)” – --bundle LAMP
No errors installing. The tail of the log is:
[2024-06-12 13:14:44 UTC] [DEBUG] SSL certificate request for the hostname : 1 : SSL certificate for host default domain>[2024-06-12 13:14:44 UTC] [DEBUG] Cleaning up temporary files in /tmp/.virtualmin-4562.
[2024-06-12 13:14:44 UTC] [DEBUG] Primary address detected as 5.78.96.218
[2024-06-12 13:14:44 UTC] [SUCCESS] Installation Complete!
[2024-06-12 13:14:44 UTC] [SUCCESS] If there were no errors above, Virtualmin should be ready
[2024-06-12 13:14:44 UTC] [SUCCESS] to configure at https://host.olivebr.com:10000 (or https://5.78.96.218:10000).

olivebr.com is with Namecheap and uses their DNS. I added an A record for host.olivebr.com.

When I go to configure, Chrome on Windows 10 whines about the cert and drops back to http. Firefox whines but lets me continue. When I sign in using root + root-password, I get:
Warning!
Login failed. Please try again.

Before getting the Hetzner server, I practiced installing Virtualmin on a clean Ubuntu 24.04 server on my local network and everything went well once I shouted at WordPress loud enough.

Thanks for any advice! Phil

Hey Phil!

SSH into your server and set the Webmin root password by running the following command:

webmin passwd root

Some providers tend to disable or even lock root accounts.

2 Likes

I’m in! Thank you so much.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.