Cannot get FastCGI running after upgrade of PHP


I recently upgraded php, now the whole apache side of the server is having a lot of trouble.

Im running CentOS release 6.5 (Final) with latest version of virtualmin.

If i set FGCId then the site was showing the source code, CGI wrapper would just download the php files.

Eventually managed, i thought, to get it working by commenting out the php_admin_value

Upon trying to use the wordpress install i ran into permissions issues, i ran phpinfo.php and saw that it was running as apache user, which is no use really as i would have to set all ownership to apache.

Below is the output of phpinfo, the apache section, attached is the virtualhost configuration.

any help greatly appreciated.

Apache Version Apache/2.2.15
Apache API Version 20051115
Server Administrator root@localhost
User/Group apache(48)/48
Max Requests Per Child: 3000 - Keep Alive: off - Max Per Connection: 100
Timeouts Connection: 60 - Keep-Alive: 15
Virtual Server Yes
Server Root /etc/httpd
Loaded Modules core prefork http_core mod_so mod_auth_basic mod_auth_digest mod_authn_file mod_authn_alias mod_authn_anon mod_authn_dbm mod_authn_default mod_authz_host mod_authz_user mod_authz_owner mod_authz_groupfile mod_authz_dbm mod_authz_default util_ldap mod_authnz_ldap mod_include mod_log_config mod_logio mod_env mod_ext_filter mod_mime_magic mod_expires mod_deflate mod_headers mod_usertrack mod_setenvif mod_mime mod_dav mod_status mod_autoindex mod_info mod_dav_fs mod_vhost_alias mod_negotiation mod_dir mod_actions mod_speling mod_userdir mod_alias mod_substitute mod_rewrite mod_proxy mod_proxy_balancer mod_proxy_ftp mod_proxy_http mod_proxy_ajp mod_proxy_connect mod_cache mod_suexec mod_disk_cache mod_cgi mod_version mod_fcgid mod_perl mod_php5 mod_ssl mod_dav_svn mod_authz_svn


You may want to check out the document titled “Why does PHP / ProFTPd no longer work after performing updates? (I’m using CentOS, and enabled third party repositories)”, that’s available here: