Cannot get domain to use new PHP version

Operating system:
OS version:
Ubuntu 18

So, I installed php 7.3, I can see it showing up in virtalmin>server config > php versions

I ran the re-check config and see

The following PHP versions are available : 7.2.34 (/usr/bin/php-cgi7.2), 7.3.24 (/usr/bin/php-cgi7.3), 7.3 (mod_php)
The following PHP execution modes are available : mod_php cgi fcgid fpm
The following PHP-FPM versions are available on this system : 7.2.3 (php7.2-fpm) 7.3.24 (php7.3-fpm)

I created a phpinfo() inside a subdomain virtual server and see it is still using PHP Version 7.2.34-8.

Why when I change the version is it not updating?


Most probably you’re hit with this bug, which we just fixed it. Expect it to be fixed with Virtualmin 6.14.

You can apply this change manually by editing /usr/share/webmin/virtual-server/ file and restarting Webmin with /etc/webmin/restart command.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.