Cannot enable SSL because mailman is not running

Because of security settings on a client PC which blocks mail access to non-SSL sites I need to install a certificate issued by a CA.

In Edit Virtual Server -> Enabled features the SSL option does not show up. I understand that is because in System Settings -> Features and Plugins the option SSL Webiste is not enabled.

However, when I enable is, I receive this error message:

Failed to save enabled features : The plugin Mailman cannot be used : The mailman queue processor /var/lib/mailman/bin/qrunner is not running on your system. It can be started in the [Bootup and Shutdown] module

But starting mailman is not successful when I thry that from Bootup and Shutdown. No error message.

Starting from the command line: systemctl start mailman exits without an error message but there is no mailman process.

In Servers -> Mailman Mailing Lists there is a message:

Virtualmin has detected that 1 virtual servers have mailman redirect URLs that do not match the Virtualmin base URL

I requested to fix that. The error message disappeared, but mailman does not start.

The production version: Debian 8, Webmin 1.800 Virtualmin 5.03.

I have another server running so I copied the virtual server to a test environment:
Debian 8, Webmin 1.881, Virtualmin 6.03
Same problem.

So in case Virtualmin is outdated, setting up a new environment and transferring the virtual server is no solution.

I don’t use mailing lists, I am just running the mail server. Why the connection with SSL. And how to solve this?

Doh… Because security settings… Man did you actually read what you said?

Yes, I actually read it. And re-read it as well. I don’t see anything I said or any error message related to security.

The error message about a different URL was resolved by VirtualMin itself and does not occur anymore. If that has anything to do with security.

What I see is something which seems to be unrelated (cannot enable SSL because mailman is not running) and for the life of it I fail to see the relation or the relation with security.

Disable mailman for that one virtual server that has it, then disable the feature in Features and Plugins.

Ahhh. I did disable mailman for that server. But I did not remove it from Features and Plugins. That did it. Thank you so much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.